summaryrefslogtreecommitdiff
path: root/dev-python/makefun
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/makefun
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/makefun')
-rw-r--r--dev-python/makefun/Manifest4
-rw-r--r--dev-python/makefun/files/makefun-1.13.1-no_pytest-runner.patch10
-rw-r--r--dev-python/makefun/makefun-1.13.1.ebuild25
-rw-r--r--dev-python/makefun/metadata.xml13
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/makefun/Manifest b/dev-python/makefun/Manifest
new file mode 100644
index 000000000000..b4f700e4480b
--- /dev/null
+++ b/dev-python/makefun/Manifest
@@ -0,0 +1,4 @@
+AUX makefun-1.13.1-no_pytest-runner.patch 184 BLAKE2B 663db5f0d235f5117a066fff19bbb940c3a2b7d7cfbe2c2b07430d85d33e0a62800aa89c38530526eeae76611a6619eee765f5fdd69d9ab38d39458d85cb104d SHA512 179e9db22717ec79d0c4ae9dc53ceee26d542eb4e3a957bb4ae4689ba808476894a8276e536214c9923140ee8307393d96b417ea8477d393e399ca4c953dfdd4
+DIST makefun-1.13.1.tar.gz 72170 BLAKE2B b1b5e76277e742ef51bcdf2bf6f1d1e761010d75bc3f20d7a8c079b368972b90775bd3bb23cf1787911a8d858549d72d4a2c9379675e59f359486bf1c49566e2 SHA512 ae103d3827673c4124d051e3c76d3d0d126c783ac7a1ea09de3801fd695439eaa549c297bd5c262184a3ee6fdf7b046065081fa3183642778148c2134d7bfc06
+EBUILD makefun-1.13.1.ebuild 625 BLAKE2B 994cbc90deb5adb50d0522b979c0ec2bc57e7c712ec817d95635584093ebd7f12e36c4c16fcec1230f55c0e2a5a0824b1354a8026581e6fe4f88e6b3652e4ea5 SHA512 a95429b516d09b5d08caaf21fd1bbd206a551eb1afaa267707c3956e77c9648e4d4a4df5b3c2b74ae256efeec680334f1cd9d6a3ccd3fc6164fe7dc9857e0d95
+MISC metadata.xml 401 BLAKE2B 0657deb821edfdf648e5bb0a95255b87df0c090c6e719a5ad94a6d3f6e2e64f36d4093a2bfddb5e8592d3d38741e8d0251c8331133113766ef2fc4caa48e88ad SHA512 cda21fbaa9b62896ba3389cf281ae35bd9a59fb0d0604e61fb3b046061de47a2535d7a98d335b66f44483ae43deadf05abde0a2285902c1c3fab2762b080dbad
diff --git a/dev-python/makefun/files/makefun-1.13.1-no_pytest-runner.patch b/dev-python/makefun/files/makefun-1.13.1-no_pytest-runner.patch
new file mode 100644
index 000000000000..659717903361
--- /dev/null
+++ b/dev-python/makefun/files/makefun-1.13.1-no_pytest-runner.patch
@@ -0,0 +1,10 @@
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -27,7 +27,6 @@
+ [options]
+ setup_requires =
+ setuptools_scm
+- pytest-runner
+ install_requires =
+ funcsigs;python_version<'3.3'
+ tests_require =
diff --git a/dev-python/makefun/makefun-1.13.1.ebuild b/dev-python/makefun/makefun-1.13.1.ebuild
new file mode 100644
index 000000000000..6cd6b05da214
--- /dev/null
+++ b/dev-python/makefun/makefun-1.13.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Small library to dynamically create Python functions"
+HOMEPAGE="https://pypi.org/project/makefun/ https://github.com/smarie/python-makefun"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.13.1-no_pytest-runner.patch
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/makefun/metadata.xml b/dev-python/makefun/metadata.xml
new file mode 100644
index 000000000000..0a2fbcffabe0
--- /dev/null
+++ b/dev-python/makefun/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">smarie/python-makefun</remote-id>
+ <remote-id type="pypi">makefun</remote-id>
+ </upstream>
+</pkgmetadata>