summaryrefslogtreecommitdiff
path: root/dev-python/magic-wormhole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-26 03:07:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-26 03:07:48 +0100
commit5923f7107d7596f9ecb6a86b451105462668601c (patch)
tree57ebb2966a1787500108baf49e27b002aaaed0ce /dev-python/magic-wormhole
parent633591ecdf876d163972f90145c0ca61e6c496fa (diff)
gentoo auto-resync : 26:05:2023 - 03:07:47
Diffstat (limited to 'dev-python/magic-wormhole')
-rw-r--r--dev-python/magic-wormhole/Manifest3
-rw-r--r--dev-python/magic-wormhole/magic-wormhole-0.12.0_p20230525.ebuild51
-rw-r--r--dev-python/magic-wormhole/metadata.xml13
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/magic-wormhole/Manifest b/dev-python/magic-wormhole/Manifest
new file mode 100644
index 000000000000..1ddca78ce3f5
--- /dev/null
+++ b/dev-python/magic-wormhole/Manifest
@@ -0,0 +1,3 @@
+DIST magic-wormhole-0.12.0_p20230525.gh.tar.gz 281332 BLAKE2B daf9e39c89d8591584b25f142de2e66757a31970179f38e2fb74e112295e637f94930127bd3c0c1cc1243ac559dc4885bab3e7892b112dbf174b0514b49051c0 SHA512 ef5be6396fb9d6e35c64baeeaaea269526f9f8127eaf1bdd7b7b693a0272885388c4d6dc9fac87f6355eff5e9fe94450aebeafd2009b7d74f6772922a2796cbd
+EBUILD magic-wormhole-0.12.0_p20230525.ebuild 1637 BLAKE2B 5b7b56e7efafe63f0e05331c9b0356e73d846e125c33f2acb4ade9828e161b58e00f36d2511317383bbbb799f213978fece189d7203e997539d6d572044f7d16 SHA512 ec85a0e720a51285df02a4b66cd99b98e028a8c48ba5c6affa50e5c9e228a610f52fbcd4e1a26cd18e0a27e34a6c22115484fa086f16b9d5c6ea108747c28197
+MISC metadata.xml 418 BLAKE2B 9f9b20483a6ce46113cc6307621122f2a5d36355ca9c8290af95b88c6ed6bb9320810da1eccf9c53d310fd8faea3796094b1c1260032406aa9adff37dc95ce51 SHA512 ef39741b0b041bf889d138efea1f784453dce8cf982d170dbfe26ace415bb186672a7bf56b1c4a586c0820997522a45f92fa40b37936f4c90ec731498c3c7b69
diff --git a/dev-python/magic-wormhole/magic-wormhole-0.12.0_p20230525.ebuild b/dev-python/magic-wormhole/magic-wormhole-0.12.0_p20230525.ebuild
new file mode 100644
index 000000000000..6a6c99bff5a9
--- /dev/null
+++ b/dev-python/magic-wormhole/magic-wormhole-0.12.0_p20230525.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+# Version 0.12.0 with additional upstream fixes for python 3.11 support and
+# miscellanous improvements
+COMMIT_SHA1="8af8888d171791943b9fab036f0e0067b87c9b59"
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Get Things From One Computer To Another, Safely"
+HOMEPAGE="https://magic-wormhole.readthedocs.io/en/latest/ https://pypi.org/project/magic-wormhole/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT_SHA1}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${P}.gh"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/automat[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/noiseprotocol[${PYTHON_USEDEP}]
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/spake2[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/twisted[ssl,${PYTHON_USEDEP}]
+ dev-python/txtorcon[${PYTHON_USEDEP}]"
+
+#
+# magic-wormhole-0.12.0_p20230525 requires the released
+# magic-wormhole-transit-relay-0.21 for setting up its unit tests. This
+# hopefully will be resolved soon with the upcoming releases (of wormhole,
+# mailbox-server, and transit-relay).
+#
+BDEPEND="
+ test? (
+ dev-python/magic-wormhole-mailbox-server[${PYTHON_USEDEP}]
+ ~dev-python/magic-wormhole-transit-relay-0.2.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/magic-wormhole/metadata.xml b/dev-python/magic-wormhole/metadata.xml
new file mode 100644
index 000000000000..c0b4cfe14855
--- /dev/null
+++ b/dev-python/magic-wormhole/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">magic-wormhole</remote-id>
+ <remote-id type="github">magic-wormhole/magic-wormhole</remote-id>
+ </upstream>
+</pkgmetadata>