summaryrefslogtreecommitdiff
path: root/dev-python/magic-wormhole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-25 03:04:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-25 03:04:18 +0100
commit4bc145ba9c79d57abcafc9b97c72bd5addd3e833 (patch)
tree6d3232c40367527f41a16208e51be62072e72efc /dev-python/magic-wormhole
parentcc6fb501ef0f4c443ce79d017dbfbd95072b14f4 (diff)
gentoo auto-resync : 25:05:2023 - 03:04:17
Diffstat (limited to 'dev-python/magic-wormhole')
-rw-r--r--dev-python/magic-wormhole/Manifest3
-rw-r--r--dev-python/magic-wormhole/magic-wormhole-0.12.0.ebuild31
-rw-r--r--dev-python/magic-wormhole/metadata.xml13
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/magic-wormhole/Manifest b/dev-python/magic-wormhole/Manifest
new file mode 100644
index 000000000000..030929f27b14
--- /dev/null
+++ b/dev-python/magic-wormhole/Manifest
@@ -0,0 +1,3 @@
+DIST magic-wormhole-0.12.0.tar.gz 274063 BLAKE2B 6a0cddd285169373926de9da26125b34457c76e456b1bfd910baed74090900a663435b0df78e5521fd91274b111d8fad56e923832cdd430b2eb27c31d8b510e3 SHA512 141244e746b0718f2c9417e8f7de6a714b0feb051aea8c7950ea0d1bc5d2e24e922bed29544fe76aa61b06aa2ce2b5f330824017af8c6030813415e6c004c716
+EBUILD magic-wormhole-0.12.0.ebuild 967 BLAKE2B 9be2b65796abbe2228d25a3fba6d3cec1b564a40ee8a86168a7ea3695fb43497df46e6437a1d43f0c1384bb3f9a1ef5a0322630925994118c49f7ddf1a2d2d0d SHA512 93ae9913edf3c5dbe360a361e86bb57ff1b54814b70660e74f82ce6bb6797218cfc0a32b39b414993ecc403a2853a948a12b93dc7b9e8746215158e95ccb6dd0
+MISC metadata.xml 418 BLAKE2B 9f9b20483a6ce46113cc6307621122f2a5d36355ca9c8290af95b88c6ed6bb9320810da1eccf9c53d310fd8faea3796094b1c1260032406aa9adff37dc95ce51 SHA512 ef39741b0b041bf889d138efea1f784453dce8cf982d170dbfe26ace415bb186672a7bf56b1c4a586c0820997522a45f92fa40b37936f4c90ec731498c3c7b69
diff --git a/dev-python/magic-wormhole/magic-wormhole-0.12.0.ebuild b/dev-python/magic-wormhole/magic-wormhole-0.12.0.ebuild
new file mode 100644
index 000000000000..d6a97bafd884
--- /dev/null
+++ b/dev-python/magic-wormhole/magic-wormhole-0.12.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Get Things From One Computer To Another, Safely"
+HOMEPAGE="https://magic-wormhole.readthedocs.io/en/latest/ https://pypi.org/project/magic-wormhole/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/automat[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/spake2[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/twisted[ssl,${PYTHON_USEDEP}]
+ dev-python/txtorcon[${PYTHON_USEDEP}]"
diff --git a/dev-python/magic-wormhole/metadata.xml b/dev-python/magic-wormhole/metadata.xml
new file mode 100644
index 000000000000..c0b4cfe14855
--- /dev/null
+++ b/dev-python/magic-wormhole/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">magic-wormhole</remote-id>
+ <remote-id type="github">magic-wormhole/magic-wormhole</remote-id>
+ </upstream>
+</pkgmetadata>