summaryrefslogtreecommitdiff
path: root/dev-python/m2r
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/m2r
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/m2r')
-rw-r--r--dev-python/m2r/Manifest2
-rw-r--r--dev-python/m2r/m2r-0.2.1.ebuild11
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/m2r/Manifest b/dev-python/m2r/Manifest
index df7ef5a0e7f3..9122949c1ef1 100644
--- a/dev-python/m2r/Manifest
+++ b/dev-python/m2r/Manifest
@@ -5,5 +5,5 @@ AUX m2r.1 9244 BLAKE2B d7ac673d0750695f8b21b6e9d0c5328ab8934dd20eb88835c655affab
AUX test.md 34 BLAKE2B 88eac9a501f3fd54ac3c9555612c7d3860d5c692170fcfeca3d75b665611b75e627443e8a54d8dbba4c820b2f793c5b933a76493381d295aefdd5ef55b7fc1d5 SHA512 c4b98b3256e14d46187d4c5cf5d3b26e4e4e0b1c6f2f61618987c234f49ea5a9bf31a94b9d2c4907bbd0685fb30138a5916b5dd3c8f92cd80bf0c7c2e657ae26
AUX test.rst 45 BLAKE2B 1bdb710270f83f8a5177fe457f3ea40bd0bd8ddd36e5acabb4d6fcbdd1cded336a736978a79efff42c7cebcd1a420d8bc4485593d675b3a66e3f427434147c9a SHA512 a2d44de89e17b5a023928fa695c8dd61163a2b59968a514b9a976f92923881ce53625930f0e05f7f257250e46f25747928f71e8f25fcb9c05445b221688077d7
DIST m2r-0.2.1.tar.gz 24455 BLAKE2B 42ec5a919301b6dee2b345a5eca9e62a1bd44186fb61dbd8cc9de6cacc34821e912f242355cc7368b755f923a433353cfa567afc480e9b8c63bf209ff9d3c624 SHA512 847f04538ee52f0b0a88cee9474ed889e8114a3a7b1fb221cdaa867ab70ca52f517250f2c8bbf795ae598c7b6614e6d03d9f6f05b7e3d56fb8087d63eb52f1bc
-EBUILD m2r-0.2.1.ebuild 1423 BLAKE2B 3f9883795817a21a4e6f7d3dff086218fef371ac0088be8b7e0354c4c93c1b10fdbc6ec1afdc6d67d282af086423d02ea982fadc2bada48fe9db62141b7b292d SHA512 2a6f2bd149bee4a4e808c293c41d77313f18a557157256fb0e137aca1b7ff841dabd258dd5a925ffdd56984e3e02a0f5474f14cfc468dbb09b488267df817ed6
+EBUILD m2r-0.2.1.ebuild 1572 BLAKE2B 1e9a6448927cec19c87d08d0cc03972d0446626f4a7ef610c3ea4f848dee8b1876efc99c9024f3ab2163504bca6cdcf29ba5e9e21c0bc33b3eb05ecd0d63617f SHA512 b1893b47f4d37bb42548fc8caa02cc51000805553f6f490e5615ca62d9f3d137c0134047a4296a9e6ac7b7669ce18e7ea92e0c19e434ac7df150a002b20b5e5a
MISC metadata.xml 484 BLAKE2B 3b355a1278f7d4228f6a050fc7ed24eca1755362843cb166c3870c8c6b9ee86d5e4fed899c2e27dd6294767197c0df1f7f081cc82a8fdccbba1bf7fdf54253e6 SHA512 df5da26b52db4a7d5f62f7c75fbd3ef51f5b59d5fc63fcf33040b3402c001065e44c2f6daf616d1b87188415bd786a85526705e7bf1b1b08c9ef50b3239d65c3
diff --git a/dev-python/m2r/m2r-0.2.1.ebuild b/dev-python/m2r/m2r-0.2.1.ebuild
index cc8e39ecf1ce..376b91573204 100644
--- a/dev-python/m2r/m2r-0.2.1.ebuild
+++ b/dev-python/m2r/m2r-0.2.1.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Markdown to reStructuredText converter"
@@ -23,7 +22,7 @@ RDEPEND="
BDEPEND="
test? (
dev-python/pygments[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )
+ )
${RDEPEND}
"
@@ -44,6 +43,12 @@ python_prepare_all() {
cp "${FILESDIR}/"test.md tests/ || die
cp "${FILESDIR}/"test.rst tests/ || die
cp "${FILESDIR}/"m2r.1 "${S}" || die
+
+ # in python 3.10, the text changed from "optional arguments" to "options".
+ # the test matches on the concrete string, make it match on the part that is shared
+ # by both versions
+ sed -e 's/optional arguments:/option/' -i tests/test_cli.py || die
+
distutils-r1_python_prepare_all
}