summaryrefslogtreecommitdiff
path: root/dev-python/m2crypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-05 04:10:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-05 04:10:14 +0100
commitfc3556aa4466d278bff2aef2f88113089def0bab (patch)
tree1f76bbf16fd77b5c04183054f423b9fe5179fcff /dev-python/m2crypto
parentcfd874bb4cf6ed8fa9b0d38cc3a81b33a793ebc8 (diff)
gentoo auto-resync : 05:07:2023 - 04:10:14
Diffstat (limited to 'dev-python/m2crypto')
-rw-r--r--dev-python/m2crypto/Manifest2
-rw-r--r--dev-python/m2crypto/m2crypto-0.39.0.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index 7401e029f03b..a0ad1d853460 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,3 +1,5 @@
DIST M2Crypto-0.38.0.tar.gz 1241269 BLAKE2B 95433090e08ff72cd2b0779491dc38b89eca159b26812e763b5b8973e3d27249a96d5a2c983b59f414184f64beb8e455dc26979310378db89dd2081741d4d17d SHA512 b1e24e3101ce0dd9f17be4cabeddc2ec0f1228b270d74ef2fb38bae8807c5025b031d0743185f06370786a3dd5c3f42129720534dcff07ea4de3c727613f8d20
+DIST M2Crypto-0.39.0.tar.gz 1248372 BLAKE2B f89793b847fae3c51a0ea79c3ba861d26b53fa12b2c8d68c3b3476bb2c944b586e875bea0c4693c213e024024096a06de0734631e546c4284d65fc5494784476 SHA512 5d8210c6204fd71f06d238c5b1fe08dd38d6b8e92db7b1e433a9e4e2fe9af46d6d55df7550716a7d05328fb3c9eed427f015b7d5a1fe33a073f0af15a82ab050
EBUILD m2crypto-0.38.0.ebuild 1732 BLAKE2B 00095b11d459ac799eeed239fe2f60a2529a1229a7aab1741a3fc3bc320d9abcf57d147114a1bd938a5877ba07aedcea2086289faab451dbb683e070a545388b SHA512 ed3c5decd518a2a9455a07d8e2b26fbc92b84c9c1fd3a00e7cd3e450790b1156c6c40991cbd1d8fdfce8d134ec8016d2957a36c5041d40c2f694ba91701f6b5e
+EBUILD m2crypto-0.39.0.ebuild 1685 BLAKE2B 6d00dd601cf0ec70f96e8e1ab0af2123a6d888e9a9b4367ff707bdca62ea965ce0f6de2f4cf3d8c3bd03e247375ebdc7881877c064ca74f4eb78c1f926a1e182 SHA512 12decb5db491f219fd4cb93fb73d816d6cc60134e7cd74d686c22c6d9f89d7b5879970d8b83fc53f44cc71a7651cf9655c8c05d4ac4b263e2d3debeb86b524c5
MISC metadata.xml 381 BLAKE2B 9581f2ef53dd3b8bfff3724e91e36733892f9c4331376861ec25cee892d63f69f4f1846e46c40bc5a5045963d91aadcc2cdf70b574bf519557afe72cffab256b SHA512 95cfd7f65c912a520f371f236a49f41b711101f5997b14fa81f027cbcabe4bf6361d1a6f647d0de6e6b7756a2c662f2336c6dea5779d00372aa5b05f0566663d
diff --git a/dev-python/m2crypto/m2crypto-0.39.0.ebuild b/dev-python/m2crypto/m2crypto-0.39.0.ebuild
new file mode 100644
index 000000000000..65fe30ad10d2
--- /dev/null
+++ b/dev-python/m2crypto/m2crypto-0.39.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{10..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="M2Crypto"
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="A Python crypto and SSL toolkit"
+HOMEPAGE="https://gitlab.com/m2crypto/m2crypto https://pypi.org/project/M2Crypto/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test abi_mips_n32 abi_mips_n64 abi_mips_o32"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=dev-lang/swig-2.0.9
+"
+RDEPEND="
+ dev-libs/openssl:=
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests setup.py
+
+swig_define() {
+ local x
+ for x; do
+ if tc-cpp-is-true "defined(${x})"; then
+ SWIG_FEATURES+=" -D${x}"
+ fi
+ done
+}
+
+src_prepare() {
+ # relies on very exact clock behavior which apparently fails
+ # with inconvenient CONFIG_HZ*
+ sed -e 's:test_server_simple_timeouts:_&:' \
+ -i tests/test_ssl.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ # setup.py looks at platform.machine() to determine swig options.
+ # For exotic ABIs, we need to give swig a hint.
+ local -x SWIG_FEATURES=
+
+ # https://bugs.gentoo.org/617946
+ swig_define __ILP32__
+
+ # https://bugs.gentoo.org/674112
+ swig_define __ARM_PCS_VFP
+
+ # Avoid similar errors to bug #688668 for MIPS
+ if use abi_mips_n32; then
+ swig_define _MIPS_SIM = _ABIN32
+ elif use abi_mips_n64; then
+ swig_define _MIPS_SIM = _ABI64
+ elif use abi_mips_o32; then
+ swig_define _MIPS_SIM = _ABIO32
+ fi
+
+ distutils-r1_python_compile --openssl="${ESYSROOT}"/usr
+}