summaryrefslogtreecommitdiff
path: root/dev-python/m2crypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-11 11:06:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-11 11:06:02 +0100
commite93a38d535f2c29b55a5756d2de99425986b0bf3 (patch)
treec0fa85c173d211181d0093e7dc031623e7b8a9a3 /dev-python/m2crypto
parentfbbf0ee3d56a6fd27adf182c6907dc745623aeaa (diff)
gentoo auto-resync : 11:08:2024 - 11:06:01
Diffstat (limited to 'dev-python/m2crypto')
-rw-r--r--dev-python/m2crypto/Manifest2
-rw-r--r--dev-python/m2crypto/m2crypto-0.42.0.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index 68517225e5ed..b42884f14354 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,3 +1,5 @@
DIST M2Crypto-0.41.0.tar.gz 1151680 BLAKE2B 6c5294294fd62ca69eec8222324ce8a1012c999aab241eba2e5b0085c0d7b598fd62f26e106bea95bfad3199abb2db9876547f521b34f45930b00540a6ecc24a SHA512 50ca5e32ae999b9ecdc7f3bbd35221b4a7523ef29e54eb4bc266457723117718955f99b9e7ac42a4cb982f0e22a94e5c852d6886d7dfb157d040ad86c17660fb
+DIST m2crypto-0.42.0.tar.gz 240072 BLAKE2B 86b9f340eb90a8fc94b09faa20a676a3a63c0c64a0902a6729face72b602a2f55941c156ecb3d522a823457d2514e96b147585264200674e11dfaba3d19790de SHA512 b36fb6d1ca401de9741118ab8d43113511bf27d32f45d2257ed70ea8d3b8a3beaf811731dbbece00a6b990366c43096c6b5f5b12d4649ae923bff98c5fc8e674
EBUILD m2crypto-0.41.0.ebuild 1534 BLAKE2B be2bfeab8edd42079d19620f7969850a4637c43696bdd8ac6d671497f936cf5b7ae7c421fcb0be4337c7fead1060c0e4a65ffeee2806b111e5670ac1330bfe3f SHA512 47179533d3a44e060e505a0a49944732ecb81d0d5518bbdf9bdea2dac9cc62d6e124fbe26c0ca71d091c0806543cee52644b39f90a5c6ee3d3cb9fc5d480e168
+EBUILD m2crypto-0.42.0.ebuild 1521 BLAKE2B 696c09dd7107ea379cda5b3bcee5934a92fde83dca8917452ad9cca474f3e4078def21f4655212fb2514d55b07139dee4aa76c2c3b70e8d920d0ba2d89aca173 SHA512 23f2a374b2bcd83ec3c40abdad78e143c0c645b7c788362485dcc9e18f5026aba75e9476f63f169e1fbf07f48cae4dc8ef7d467cd8907ff9a8423bd0d397bd96
MISC metadata.xml 381 BLAKE2B 9581f2ef53dd3b8bfff3724e91e36733892f9c4331376861ec25cee892d63f69f4f1846e46c40bc5a5045963d91aadcc2cdf70b574bf519557afe72cffab256b SHA512 95cfd7f65c912a520f371f236a49f41b711101f5997b14fa81f027cbcabe4bf6361d1a6f647d0de6e6b7756a2c662f2336c6dea5779d00372aa5b05f0566663d
diff --git a/dev-python/m2crypto/m2crypto-0.42.0.ebuild b/dev-python/m2crypto/m2crypto-0.42.0.ebuild
new file mode 100644
index 000000000000..b7a299e25b71
--- /dev/null
+++ b/dev-python/m2crypto/m2crypto-0.42.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYPI_PN="M2Crypto"
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="A Python crypto and SSL toolkit"
+HOMEPAGE="
+ https://gitlab.com/m2crypto/m2crypto/
+ https://pypi.org/project/M2Crypto/
+"
+
+# openssl via src/SWIG/_lib11_compat.i
+LICENSE="MIT openssl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="abi_mips_n32 abi_mips_n64 abi_mips_o32"
+
+DEPEND="
+ dev-libs/openssl:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-lang/swig-2.0.9
+"
+
+swig_define() {
+ local x
+ for x; do
+ if tc-cpp-is-true "defined(${x})"; then
+ SWIG_FEATURES+=" -D${x}"
+ fi
+ done
+}
+
+src_prepare() {
+ # relies on very exact clock behavior which apparently fails
+ # with inconvenient CONFIG_HZ*
+ sed -e 's:test_server_simple_timeouts:_&:' \
+ -i tests/test_ssl.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ # setup.py looks at platform.machine() to determine swig options.
+ # For exotic ABIs, we need to give swig a hint.
+ local -x SWIG_FEATURES=
+
+ # https://bugs.gentoo.org/617946
+ swig_define __ILP32__
+
+ # https://bugs.gentoo.org/674112
+ swig_define __ARM_PCS_VFP
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest -b -v tests.alltests.suite ||
+ die "Tests failed for ${EPYTHON}"
+}