summaryrefslogtreecommitdiff
path: root/dev-python/m2crypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-14 11:36:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-14 11:36:24 +0000
commit3a5772102e4f2b6f9cc46f461c90970060ae0c5e (patch)
treed5aebb2508413a75408fd60bd4cb2c886b78ba89 /dev-python/m2crypto
parentf7379fa6ffb6e47eabc62d0d832a5bcad1db9591 (diff)
gentoo auto-resync : 14:02:2024 - 11:36:23
Diffstat (limited to 'dev-python/m2crypto')
-rw-r--r--dev-python/m2crypto/Manifest2
-rw-r--r--dev-python/m2crypto/m2crypto-0.41.0.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index 709871fd62d9..fc0c499dcffd 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,3 +1,5 @@
DIST M2Crypto-0.40.1.tar.gz 1266138 BLAKE2B a44de6b66695e0fbbba671682a7773ddbbd15225d27329d357e0005e395a70c6b006401ec30fb6938c9c4683377519844ea646df7c176181977139f6381c6907 SHA512 ca914de14621af4aa9b7f11664702557e596438cc76869478a2a75eb37ca14243e7064db7e32985834260ffa9136836884e60916d542a685ac3f1481b9320b69
+DIST M2Crypto-0.41.0.tar.gz 1151680 BLAKE2B 6c5294294fd62ca69eec8222324ce8a1012c999aab241eba2e5b0085c0d7b598fd62f26e106bea95bfad3199abb2db9876547f521b34f45930b00540a6ecc24a SHA512 50ca5e32ae999b9ecdc7f3bbd35221b4a7523ef29e54eb4bc266457723117718955f99b9e7ac42a4cb982f0e22a94e5c852d6886d7dfb157d040ad86c17660fb
EBUILD m2crypto-0.40.1.ebuild 1730 BLAKE2B 95f053448caf4c7a67f920b9cbad637878ea87f5890965b1f6cb6c144bea0226488d9412264cd705e847adae03a290483e59699ac0b7b57d6b9d5a2a4de72a82 SHA512 be514ce55d0d88ccac80490f49746644f9f6c202924daa03c22f11e092a579534fc08803edc57d364bb49b097c4cf84eae76276a2a60ef2722d1703dbc64749d
+EBUILD m2crypto-0.41.0.ebuild 1541 BLAKE2B 2a1008a1edbe4c26e88d28b6df0bca0980801f033e529204de4cd6f6196c938a7b7b35325f8f0d4d70bd2b09fcb628d3e828f4737c95fb3b072320ceeb5e91b8 SHA512 4a274540c579b23d5fd0a0200cc62b9953b52533ac390c18fb8be4e6167e42af017b5273aaa81b3cb40694b9d92798ab29c12b851ca220dae294c94ff761821f
MISC metadata.xml 381 BLAKE2B 9581f2ef53dd3b8bfff3724e91e36733892f9c4331376861ec25cee892d63f69f4f1846e46c40bc5a5045963d91aadcc2cdf70b574bf519557afe72cffab256b SHA512 95cfd7f65c912a520f371f236a49f41b711101f5997b14fa81f027cbcabe4bf6361d1a6f647d0de6e6b7756a2c662f2336c6dea5779d00372aa5b05f0566663d
diff --git a/dev-python/m2crypto/m2crypto-0.41.0.ebuild b/dev-python/m2crypto/m2crypto-0.41.0.ebuild
new file mode 100644
index 000000000000..91e131862e17
--- /dev/null
+++ b/dev-python/m2crypto/m2crypto-0.41.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="M2Crypto"
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="A Python crypto and SSL toolkit"
+HOMEPAGE="
+ https://gitlab.com/m2crypto/m2crypto/
+ https://pypi.org/project/M2Crypto/
+"
+
+# openssl via src/SWIG/_lib11_compat.i
+LICENSE="MIT openssl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="abi_mips_n32 abi_mips_n64 abi_mips_o32"
+
+DEPEND="
+ dev-libs/openssl:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-lang/swig-2.0.9
+"
+
+swig_define() {
+ local x
+ for x; do
+ if tc-cpp-is-true "defined(${x})"; then
+ SWIG_FEATURES+=" -D${x}"
+ fi
+ done
+}
+
+src_prepare() {
+ # relies on very exact clock behavior which apparently fails
+ # with inconvenient CONFIG_HZ*
+ sed -e 's:test_server_simple_timeouts:_&:' \
+ -i tests/test_ssl.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ # setup.py looks at platform.machine() to determine swig options.
+ # For exotic ABIs, we need to give swig a hint.
+ local -x SWIG_FEATURES=
+
+ # https://bugs.gentoo.org/617946
+ swig_define __ILP32__
+
+ # https://bugs.gentoo.org/674112
+ swig_define __ARM_PCS_VFP
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest -b -v tests.alltests.suite ||
+ die "Tests failed for ${EPYTHON}"
+}