summaryrefslogtreecommitdiff
path: root/dev-python/m2crypto/m2crypto-0.27.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
commit89c6c06b8c42107dd231687a1012354e7d3039fc (patch)
treedad94f4da8a6694f3cb99f7048be2f9cf5f78f97 /dev-python/m2crypto/m2crypto-0.27.0.ebuild
parent796cae72cf9ed18ba01256ac1f83a686a2a76036 (diff)
gentoo resync : 26.11.2017
Diffstat (limited to 'dev-python/m2crypto/m2crypto-0.27.0.ebuild')
-rw-r--r--dev-python/m2crypto/m2crypto-0.27.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/m2crypto/m2crypto-0.27.0.ebuild b/dev-python/m2crypto/m2crypto-0.27.0.ebuild
index d5e3b6201594..7c3f0565c4e4 100644
--- a/dev-python/m2crypto/m2crypto-0.27.0.ebuild
+++ b/dev-python/m2crypto/m2crypto-0.27.0.ebuild
@@ -36,6 +36,14 @@ S="${WORKDIR}/${MY_PN}-${PV}"
RESTRICT=test
python_compile() {
+ # setup.py looks at platform.machine() to determine swig options.
+ # For exotic ABIs, we need to give swig a hint.
+ # https://bugs.gentoo.org/617946
+ # TODO: Fix cross-compiles
+ local -x SWIG_FEATURES=
+ case ${ABI} in
+ x32) SWIG_FEATURES="-D__ILP32__" ;;
+ esac
distutils-r1_python_compile --openssl="${EPREFIX}"/usr
}