summaryrefslogtreecommitdiff
path: root/dev-python/lz4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/lz4
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/lz4')
-rw-r--r--dev-python/lz4/Manifest6
-rw-r--r--dev-python/lz4/files/test.py16
-rw-r--r--dev-python/lz4/lz4-0.10.1.ebuild24
-rw-r--r--dev-python/lz4/lz4-0.8.2.ebuild35
-rw-r--r--dev-python/lz4/metadata.xml15
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
new file mode 100644
index 000000000000..2644fcd48b13
--- /dev/null
+++ b/dev-python/lz4/Manifest
@@ -0,0 +1,6 @@
+AUX test.py 269 BLAKE2B d0b9ff664ca4a954cb8ebf227a1b1c80f1eff8a9bacaf1cebf2f359a6a14dfa3d2f418820d3917a9107c66f4a8aaaa380cf749a9faf2cafb5265364a1955830d SHA512 7968adb54b414a8dc1ba9b3b8ba4f11695564239786cd37474122ce83f8976920206fec2b846eefcacdd307da6c9f6ac73ead87c78dfefab746540021f44964c
+DIST lz4-0.10.1.tar.gz 92068 BLAKE2B e581540036d1008c5efa008a1b980c1bd612bab94635b7a506e230921bd17c534fb99272e3ea09bc5be4faf09e0a8f701224c433df1615b4e708d620a23e1149 SHA512 538880742257e08b027c45c33aa29e12d7303826f63817d1f6d316ea9b69dfb20710a4f573499ce141cffd12fbac701305405521cb815e2329333934e7e1f2c9
+DIST lz4-0.8.2.tar.gz 30818 BLAKE2B ec51d733ebd33fcb00d3d3b634d11be39d92b14741a595139e23b5b067955a43ca325a0a655233a5ae3a62e18a1cf70cc21787d443703fc1a56ab7a765d5e2f4 SHA512 e516d5c3309f214fa422b040a0aacdda079395624dd4f5548ed7af637b1594012aac75b309cef260b41c10a623410f815fc089b54ca5d80955d5f2ead12841b1
+EBUILD lz4-0.10.1.ebuild 582 BLAKE2B a0eef30d3338a143205778441e6d6cf01435cb2edd4f1e36afb37773475ba745dfadd0d6267e7f40e112ed1c37b39f61c2e465395ad6d4f748724c48990ded32 SHA512 ccd93c915eec0670f17641e95e50e094365db1365d2d498ed05f46f2fef2a3ff91705d413dc2fa0fb4b1c212e56e0c0e5902b5cdfb18f3b71a7e1f89b7c9c648
+EBUILD lz4-0.8.2.ebuild 814 BLAKE2B ee913dcceefcecc7da972343852c09d9320505e888e257042b749a4c296d6fa76a213874a9da3c76b94b98817760a47e6847d9c9ec20384b1a480e3de38ffc4d SHA512 18a35a0f8888997cf34ad09790e13de1f700536914a2d4bf5dbf504fdbcceef6825052981d771b722e3ed716a9bf591672e7765b76bb5d5d253dd416cefb7d3c
+MISC metadata.xml 465 BLAKE2B 3eeb9b063e836d19b4ebfed81a89895f9d4e650b1788ca602f77f4cf3b5ad94cd6af93788293b9656baac1bce29a90a957c8d4afd02ee25b2aae42aefe211a37 SHA512 e5f75916075710426f9a7b875aaeb1239b948f11ac97a8d8bc45032d99985d6659916cd3c126bd37fb0fa53c97cca5b4eeeb4228180633809edc01af3b89ad91
diff --git a/dev-python/lz4/files/test.py b/dev-python/lz4/files/test.py
new file mode 100644
index 000000000000..9469a03da328
--- /dev/null
+++ b/dev-python/lz4/files/test.py
@@ -0,0 +1,16 @@
+import lz4
+import sys
+
+
+import unittest
+import os
+
+class TestLZ4(unittest.TestCase):
+
+ def test_random(self):
+ DATA = os.urandom(128 * 1024) # Read 128kb
+ self.assertEqual(DATA, lz4.loads(lz4.dumps(DATA)))
+
+if __name__ == '__main__':
+ unittest.main()
+
diff --git a/dev-python/lz4/lz4-0.10.1.ebuild b/dev-python/lz4/lz4-0.10.1.ebuild
new file mode 100644
index 000000000000..cbac3c788121
--- /dev/null
+++ b/dev-python/lz4/lz4-0.10.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die
+}
diff --git a/dev-python/lz4/lz4-0.8.2.ebuild b/dev-python/lz4/lz4-0.8.2.ebuild
new file mode 100644
index 000000000000..91f8666013ed
--- /dev/null
+++ b/dev-python/lz4/lz4-0.8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/steeve/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed \
+ -e '/nose/s:setup_requires:test_requires:g' \
+ -i setup.py || die
+ mkdir "${S}"/tests
+ cp "${FILESDIR}"/test.py "${S}"/tests
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test || dies "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/lz4/metadata.xml b/dev-python/lz4/metadata.xml
new file mode 100644
index 000000000000..503d76895130
--- /dev/null
+++ b/dev-python/lz4/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">lz4</remote-id>
+ <remote-id type="github">steeve/python-lz4</remote-id>
+ </upstream>
+</pkgmetadata>