summaryrefslogtreecommitdiff
path: root/dev-python/lz4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-27 22:42:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-27 22:42:39 +0000
commit417348c68a53a9317b6afbf343381518a405f682 (patch)
tree2436ae4cc1751690d448293f351e3fa529909437 /dev-python/lz4
parent4f5eafd9cc8e9b40e20b0a1abd96f1bcd634d0a0 (diff)
gentoo auto-resync : 27:01:2025 - 22:42:39
Diffstat (limited to 'dev-python/lz4')
-rw-r--r--dev-python/lz4/Manifest2
-rw-r--r--dev-python/lz4/lz4-4.4.3.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index 161e99554e0c..1d61c8ad160b 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1,3 +1,5 @@
DIST lz4-4.3.3.tar.gz 171509 BLAKE2B 7db336fd488ca1ba6bb80ba6a6e66bf1499004bb1ba46a3451c90721d7bb76f49ac5fc5bb5f884e350a29b565a7db14fccb907da925f7b5d14474e030e967e77 SHA512 9bdacf6766cca5d1c59f0a0f795910da104ce51d4c43057c4c07fed98765881a702604d60d22a10dea937c4d683e3fcf07c26a6c7a7b5a15b45759fcedb55900
+DIST lz4-4.4.3.tar.gz 171848 BLAKE2B 54873ac48b5b43787dd45c92056af2d302e018c0b78acb56ccef50becb4073ded1dead6d02ef203b239a4699e0af4527da04a74d3550a5a36fcdc88dda98772c SHA512 b02899f3011453f77e99aa31c7dc717a7d0ca636475e9ead617196d906e3e2abcee511e84f68e9071b27227cad8ece7fb5f78c04bd8f44cc0959bb687b72e73f
EBUILD lz4-4.3.3.ebuild 978 BLAKE2B e0ee20947a00ac05e43bf535d10be2bf24aba0b9637362dbcb75ecece66f3e273b89e0f84d74fc6dfcd6ec061ed4ba317a08b74c26dbac4e9caeeea666005f44 SHA512 445dc61ddc379e269dbe38dd9d1c5f7eac53934d04d4608be918ed0a0a76692027e80877ebbe54a69e9cb47e5000a17b31e0bfdce93135b1d04056f4f709c40e
+EBUILD lz4-4.4.3.ebuild 982 BLAKE2B 93e5d5fd9597daf906285cfb88ee2a831dc8b9ec305b969d6ea9e7930945216c8ea866cfd0897357ba5d8882ce976a7cd916a74b394bd9c9b9cb7d3feb0926a0 SHA512 5a041490383fc693248894ec78f6e358b09be676d2daeaf03e62a80c5e5805e49cee0875a4fe73abfcec0d5f97e693c02274eca41ad58cc258cdc96261c0773c
MISC metadata.xml 454 BLAKE2B b02d4acc9eb7d4fb35bf36371cb660d099c77f807fc08fc351b7e0e1d2e0199fdab82d83bb6bc31a56bfdb9a5b020b2f57aa9b89b59a7e5c22fcce554b6b0859 SHA512 a1b61eb4d3ce636b10abcff25ee3315bf5ecb3bdee58e1c45ff99f0b40717b13e3a8ec33c9abcb926bd716990a31749b1bf6729d8137b7859857318c386a8ec7
diff --git a/dev-python/lz4/lz4-4.4.3.ebuild b/dev-python/lz4/lz4-4.4.3.ebuild
new file mode 100644
index 000000000000..13562005ac5c
--- /dev/null
+++ b/dev-python/lz4/lz4-4.4.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="
+ https://github.com/python-lz4/python-lz4/
+ https://pypi.org/project/lz4/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ app-arch/lz4:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+# note: test suite fails with xdist
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # lz4.stream is not officially supported and not installed by default
+ # (we do not support installing it at the moment)
+ tests/stream
+ )
+
+ rm -rf lz4 || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}