summaryrefslogtreecommitdiff
path: root/dev-python/loky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-30 19:43:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-30 19:43:35 +0100
commitb7efdd771aad99c9a6509a5f85a80a1f7cfd55f3 (patch)
tree02f9d01894c5e75c1d01e1c85038384cb6d1da64 /dev-python/loky
parente2e7cc7d880b593b2bc94bf648dff853c97225f2 (diff)
gentoo auto-resync : 30:06:2023 - 19:43:35
Diffstat (limited to 'dev-python/loky')
-rw-r--r--dev-python/loky/Manifest2
-rw-r--r--dev-python/loky/loky-3.4.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index 2fd0cfc1e6aa..2eabae767653 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1,3 +1,5 @@
DIST loky-3.4.0.gh.tar.gz 143864 BLAKE2B bebfa2c934e4645c5cd1a4c62792bccd9b5a4ef3c9a104809b57f35ba3318596717bf82714c1b7583675bdc504dc0a2054a88009d964a900176d353a54add52c SHA512 d8113f6f6c173c208b90c29bc4a296d7844f7010cfcabbd8d55106b8e93f256b2debb86aa993a33c41f40fcdd4f00c1e1e010dbe4a184b138da357652315657c
+DIST loky-3.4.1.gh.tar.gz 143933 BLAKE2B b55dc9fe431769de6bc7f8d9854c40a361566d9c0325c7037255c5ce2b9875ff071743892ec5db53be7744955558195eb40fc5467917eeba3d533c68f285a1ec SHA512 435dc24a0532e6a40a67613fd1e13a06439ffe00c28b90fa36ff02255b67e0dd99d515f5659a36aa1049a9df73b16c1088989a1379a8492ebc5dbf1e53a37a06
EBUILD loky-3.4.0.ebuild 1151 BLAKE2B 4c51cb64310ef438cffe096fd57780305dcdcec703a9be06006f3eae1b037e4d0567994e1453c19b44e9ae82d46d2b91999b213e5b629a2709e7387a4f0ee843 SHA512 bf1a4396f6b351c1126e35b8095a2ec252f2f5893d38459dde6706a61eb2f6edafd22f44d208838ca76448ad70f625dd8f77de48e8361fc0a84b5b55d768a28d
+EBUILD loky-3.4.1.ebuild 1155 BLAKE2B 8a1270424e0118447209a930590014c6532623cac2fc252334b585d8b2a76754dd0ea19eefbafb069f30b3400320e05700d212ff037705620bb794f67dab36f8 SHA512 a53aedc34cc2d87a0c7827122d607dca482422e00e2aa623f5a8ded1bd72f6aeb5008ae60426fb90524eb30ea214d44d90380846f34db2572928152cdcd63909
MISC metadata.xml 383 BLAKE2B 9d990e2f5b4fbf959925d9d7c1f03ecb3acddcc8564c9362f14741d531d79f3e4c6d98a8c84695d8b1f761fa11a80e768b8e8b48ff8be314732d7f574d767223 SHA512 89d9a1f5c253bf99992d16b974d81175d1ae0d17649ffe1a485430735bec38f45e8e1a35c9ba2d99cb1610db3b200adb5af847b2a161c348e29f0cfa89f8076f
diff --git a/dev-python/loky/loky-3.4.1.ebuild b/dev-python/loky/loky-3.4.1.ebuild
new file mode 100644
index 000000000000..bc6340ec7ab4
--- /dev/null
+++ b/dev-python/loky/loky-3.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Robust and reusable Executor for joblib"
+HOMEPAGE="
+ https://github.com/joblib/loky/
+ https://pypi.org/project/loky/
+"
+SRC_URI="
+ https://github.com/joblib/loky/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ EPYTEST_DESELECT=(
+ # docker, seriously?
+ tests/test_loky_module.py::test_cpu_count_cfs_limit
+ # hangs, and even pytest-timeout does not help
+ tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill
+ tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
+ )
+
+ # high memory test needs a lot of memory + is broken on 32-bit platforms
+ epytest --skip-high-memory
+}