summaryrefslogtreecommitdiff
path: root/dev-python/loky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-06 16:19:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-06 16:19:28 +0000
commit9afce155a599e5f4518f3c7913b6424ac13be12e (patch)
tree60420eafdcf940c0e4555d9aa8e4e9017a646344 /dev-python/loky
parenteb7aa327b218d640c8bda63ba0fd1ace2bd2d17b (diff)
gentoo auto-resync : 06:11:2023 - 16:19:27
Diffstat (limited to 'dev-python/loky')
-rw-r--r--dev-python/loky/Manifest2
-rw-r--r--dev-python/loky/loky-3.4.1.ebuild9
2 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index a12decd2c2b4..71d95181dec4 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1,3 +1,3 @@
DIST loky-3.4.1.gh.tar.gz 143933 BLAKE2B b55dc9fe431769de6bc7f8d9854c40a361566d9c0325c7037255c5ce2b9875ff071743892ec5db53be7744955558195eb40fc5467917eeba3d533c68f285a1ec SHA512 435dc24a0532e6a40a67613fd1e13a06439ffe00c28b90fa36ff02255b67e0dd99d515f5659a36aa1049a9df73b16c1088989a1379a8492ebc5dbf1e53a37a06
-EBUILD loky-3.4.1.ebuild 1331 BLAKE2B 666dc6a07666f9624c555ed2cc40d42519eb5d7ed2846c952cbd2762fa6206378b23db0ae12ea0b5a69d484bad49763b34d99fee7aefef95d1d015f8a5a63885 SHA512 4726b00de7c95bf922dff98a8faccebeb9064904f53893b84566336549f9b2c068afbe83847f98ee8f68567104ab7130e47b65d4a731d13f04f9b3d92551c1c3
+EBUILD loky-3.4.1.ebuild 1800 BLAKE2B 1185f91a7ba84e94fcdf2ffdda932a34d7232bc1585fd94f029404bc0baaa812e135df90b71e0e6234e282f1e1c014fcd375f75cac5f55414168be4f7a01f113 SHA512 e44d328c59dbfb239e3f415ebefda4399c646510cad12586e8eef111b97888e337b5473133fd0137b8a5bb8dca0724777d4db720c0e7fb72818723d4c696df1c
MISC metadata.xml 383 BLAKE2B 9d990e2f5b4fbf959925d9d7c1f03ecb3acddcc8564c9362f14741d531d79f3e4c6d98a8c84695d8b1f761fa11a80e768b8e8b48ff8be314732d7f574d767223 SHA512 89d9a1f5c253bf99992d16b974d81175d1ae0d17649ffe1a485430735bec38f45e8e1a35c9ba2d99cb1610db3b200adb5af847b2a161c348e29f0cfa89f8076f
diff --git a/dev-python/loky/loky-3.4.1.ebuild b/dev-python/loky/loky-3.4.1.ebuild
index 456f7062da8e..350d7adf44ee 100644
--- a/dev-python/loky/loky-3.4.1.ebuild
+++ b/dev-python/loky/loky-3.4.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 multiprocessing
@@ -40,9 +40,16 @@ python_test() {
EPYTEST_DESELECT=(
# docker, seriously?
tests/test_loky_module.py::test_cpu_count_cfs_limit
+ tests/test_loky_module.py::test_cpu_count_cgroup_limit
# hangs, and even pytest-timeout does not help
tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill
tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
+ # Python 3.12 raises an additional warning due to the use of fork()
+ # in a multithreaded process, the additional warning breaks this test
+ # since the expected warning is no longer the first.
+ # This is harmless, skip test for now
+ tests/test_worker_timeout.py::TestTimeoutExecutor::test_worker_timeout_shutdown_no_deadlock
+ tests/test_reusable_executor.py::TestResizeExecutor::test_resize_after_timeout
)
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1