summaryrefslogtreecommitdiff
path: root/dev-python/loky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-17 22:03:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-17 22:03:16 +0100
commit94dd707d272879a8dfdd31d71113b1b7bba98366 (patch)
tree615875fa702a02f83e99f52ddb3a3fb0375a5674 /dev-python/loky
parent29ef84a753ab20dbbb228238713a3c7443c6520e (diff)
gentoo auto-resync : 17:10:2023 - 22:03:16
Diffstat (limited to 'dev-python/loky')
-rw-r--r--dev-python/loky/Manifest2
-rw-r--r--dev-python/loky/loky-3.4.1.ebuild7
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index 2f34784980d5..a12decd2c2b4 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1,3 +1,3 @@
DIST loky-3.4.1.gh.tar.gz 143933 BLAKE2B b55dc9fe431769de6bc7f8d9854c40a361566d9c0325c7037255c5ce2b9875ff071743892ec5db53be7744955558195eb40fc5467917eeba3d533c68f285a1ec SHA512 435dc24a0532e6a40a67613fd1e13a06439ffe00c28b90fa36ff02255b67e0dd99d515f5659a36aa1049a9df73b16c1088989a1379a8492ebc5dbf1e53a37a06
-EBUILD loky-3.4.1.ebuild 1176 BLAKE2B 9eed0eecdae5794f73c66afe658fe547c96a9b8deb0feb19ade3e98ac6599911e2eb6eb7cc966e69105c98c90e652e5c7a3cbab1e5cd47fed0b85085145cb476 SHA512 d2cd6713dce03c3be11e0a0516fa895ba6f3cc281841bfd60cd9e5df2446a5c1fb4201a4e7180894692254748ae79aa22009a1b922ef20eb9c85e8ea6dcc38bd
+EBUILD loky-3.4.1.ebuild 1331 BLAKE2B 666dc6a07666f9624c555ed2cc40d42519eb5d7ed2846c952cbd2762fa6206378b23db0ae12ea0b5a69d484bad49763b34d99fee7aefef95d1d015f8a5a63885 SHA512 4726b00de7c95bf922dff98a8faccebeb9064904f53893b84566336549f9b2c068afbe83847f98ee8f68567104ab7130e47b65d4a731d13f04f9b3d92551c1c3
MISC metadata.xml 383 BLAKE2B 9d990e2f5b4fbf959925d9d7c1f03ecb3acddcc8564c9362f14741d531d79f3e4c6d98a8c84695d8b1f761fa11a80e768b8e8b48ff8be314732d7f574d767223 SHA512 89d9a1f5c253bf99992d16b974d81175d1ae0d17649ffe1a485430735bec38f45e8e1a35c9ba2d99cb1610db3b200adb5af847b2a161c348e29f0cfa89f8076f
diff --git a/dev-python/loky/loky-3.4.1.ebuild b/dev-python/loky/loky-3.4.1.ebuild
index 8503470eaf5a..456f7062da8e 100644
--- a/dev-python/loky/loky-3.4.1.ebuild
+++ b/dev-python/loky/loky-3.4.1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
DESCRIPTION="Robust and reusable Executor for joblib"
HOMEPAGE="
@@ -30,6 +30,7 @@ BDEPEND="
test? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"
@@ -44,6 +45,8 @@ python_test() {
tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
)
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# high memory test needs a lot of memory + is broken on 32-bit platforms
- epytest --skip-high-memory
+ epytest --skip-high-memory \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
}