summaryrefslogtreecommitdiff
path: root/dev-python/loky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-15 11:48:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-15 11:48:08 +0100
commit04fc7f10cec12efb1240344a0090b539e24ad0f3 (patch)
tree130fb059a6b83e95af28b97b0f55c716d48924bf /dev-python/loky
parent0bec4ab1937eed98ee24e2d48f0cfec46de2fc58 (diff)
gentoo auto-resync : 15:04:2023 - 11:48:08
Diffstat (limited to 'dev-python/loky')
-rw-r--r--dev-python/loky/Manifest2
-rw-r--r--dev-python/loky/loky-3.4.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index a92ea21362bc..9f1efeaf4010 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1,3 +1,5 @@
DIST loky-3.3.0.gh.tar.gz 141130 BLAKE2B 35560dca81cf41e03b24c8be6e70952c19b88fc9794cb13d7c910ac67ec4554555233026a215c6f147dc1354ad11bc14117b4eb6455ba758b79ea6650dc01f62 SHA512 120f771c75fe8691a198c93a91bf683af3d32c1bcaf2fa3e9c439d16546bff9feb6ce203667bd6c4e06ac326500b7bd117948e4deea6f53b04682af1f8d65734
+DIST loky-3.4.0.gh.tar.gz 143864 BLAKE2B bebfa2c934e4645c5cd1a4c62792bccd9b5a4ef3c9a104809b57f35ba3318596717bf82714c1b7583675bdc504dc0a2054a88009d964a900176d353a54add52c SHA512 d8113f6f6c173c208b90c29bc4a296d7844f7010cfcabbd8d55106b8e93f256b2debb86aa993a33c41f40fcdd4f00c1e1e010dbe4a184b138da357652315657c
EBUILD loky-3.3.0.ebuild 1115 BLAKE2B 0400dbb2fb6e217a4c8db42ae61a5d1c427dbcab78301062a983d8731610e665257abd551a3048fa6cace1305dd609215fcd0d9a4069e63f9ec8a8f7daa6e90a SHA512 578d6f09cff9c0f286db45dd85dc29514d26e163e5bdc7dbb8aed1e2169bcfb0a49374c607191de1f67e1ed64eea913c7d21ee17a7f44ef5c1871c6aa6395640
+EBUILD loky-3.4.0.ebuild 1154 BLAKE2B a18056c345e9cc9b3b638bae8462050cf18be26b264f5b8742c5082f054e7e868b7d82c6864081e6f5fe947e2c284b58356a128c007a7984e60a9d204aed837d SHA512 529c1b4fb8a3a8124a957120a86a08994f085ca46489f5d291d68c699defc82019b9a4fe55b757b884c7211eee580614b1610260eb1631eadce08ff82455b662
MISC metadata.xml 383 BLAKE2B 9d990e2f5b4fbf959925d9d7c1f03ecb3acddcc8564c9362f14741d531d79f3e4c6d98a8c84695d8b1f761fa11a80e768b8e8b48ff8be314732d7f574d767223 SHA512 89d9a1f5c253bf99992d16b974d81175d1ae0d17649ffe1a485430735bec38f45e8e1a35c9ba2d99cb1610db3b200adb5af847b2a161c348e29f0cfa89f8076f
diff --git a/dev-python/loky/loky-3.4.0.ebuild b/dev-python/loky/loky-3.4.0.ebuild
new file mode 100644
index 000000000000..0ab8fd36be97
--- /dev/null
+++ b/dev-python/loky/loky-3.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Robust and reusable Executor for joblib"
+HOMEPAGE="
+ https://github.com/joblib/loky/
+ https://pypi.org/project/loky/
+"
+SRC_URI="
+ https://github.com/joblib/loky/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ EPYTEST_DESELECT=(
+ # docker, seriously?
+ tests/test_loky_module.py::test_cpu_count_cfs_limit
+ # hangs, and even pytest-timeout does not help
+ tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill
+ tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
+ )
+
+ # high memory test needs a lot of memory + is broken on 32-bit platforms
+ epytest --skip-high-memory
+}