summaryrefslogtreecommitdiff
path: root/dev-python/loky/loky-2.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/loky/loky-2.9.0.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/loky/loky-2.9.0.ebuild')
-rw-r--r--dev-python/loky/loky-2.9.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/loky/loky-2.9.0.ebuild b/dev-python/loky/loky-2.9.0.ebuild
deleted file mode 100644
index d1db85d53e51..000000000000
--- a/dev-python/loky/loky-2.9.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Robust and reusable Executor for joblib"
-HOMEPAGE="https://github.com/joblib/loky"
-SRC_URI="
- https://github.com/joblib/loky/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-libc.patch
- "${FILESDIR}"/${P}-fix-py3.10-tests.patch
-)
-
-python_test() {
- local args=(
- # docker, seriously?
- --deselect 'tests/test_loky_module.py::test_cpu_count_cfs_limit'
- # hangs, and even pytest-timeout does not help
- --deselect 'tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill'
- # one test that uses a lot of memory, also broken on 32-bit
- # platforms
- --skip-high-memory
- # breaks teardown
- -p no:xvfb
- )
-
- epytest "${args[@]}"
-}