summaryrefslogtreecommitdiff
path: root/dev-python/logical-unification
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/logical-unification
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/logical-unification')
-rw-r--r--dev-python/logical-unification/Manifest3
-rw-r--r--dev-python/logical-unification/logical-unification-0.4.4.ebuild33
-rw-r--r--dev-python/logical-unification/metadata.xml13
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/logical-unification/Manifest b/dev-python/logical-unification/Manifest
new file mode 100644
index 000000000000..79e50b648385
--- /dev/null
+++ b/dev-python/logical-unification/Manifest
@@ -0,0 +1,3 @@
+DIST logical-unification-0.4.4.gh.tar.gz 44705 BLAKE2B 2a120bd143fba81554a94bea12e007a1a1230f9cb47304e7248acbdbda59666e46bbfcfddf2fa95e422eecd5978a3eec51f1648e995c46e8467b423a96970cf9 SHA512 0742b105702efc9d17b48ce573e02e119adfbc30c0835fe2bae1266193d8e9ecefe0caec691cc214a29ecae6f7051c5b0d2f05f8d3910c29893d1822a97f5d5a
+EBUILD logical-unification-0.4.4.ebuild 687 BLAKE2B b46edebab384ef2775e8ea83feecfe69493c574413f8054e0119f04ea7e7943abefcbfa770b0e48bf5ffe0df192c5efcca5fee6dc154f275c12d5637d0dfbf17 SHA512 4155a13ec535682ddffeb901a7d58817628d5f4c305736c6a492682b92050d139cc4ca6962a3aa470337e94c5b71767e53e2dd5620032c4ae2772c73cb90a299
+MISC metadata.xml 411 BLAKE2B 41b22447e02d0d7cb7b13523abafe18bf4c01033ffe561c022d32c9896fe85272a1357682b678e0d679d01d992cdef1e445358280c581dcc1071a6e7b1f7e587 SHA512 21e61a22962dd3b4eb70efa40e2dd74660c540f79e13a3d9015494681432361f660003b3fa533fdd82faeb1e76bd4486c40478c99076e65997da14de1c0d8315
diff --git a/dev-python/logical-unification/logical-unification-0.4.4.ebuild b/dev-python/logical-unification/logical-unification-0.4.4.ebuild
new file mode 100644
index 000000000000..47e6bb170f17
--- /dev/null
+++ b/dev-python/logical-unification/logical-unification-0.4.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Logical unification in Python"
+HOMEPAGE="
+ https://pypi.org/project/logical-unification/
+ https://github.com/pythological/unification/
+"
+SRC_URI="
+ https://github.com/pythological/unification/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/unification-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_benchmarks.py
+)
diff --git a/dev-python/logical-unification/metadata.xml b/dev-python/logical-unification/metadata.xml
new file mode 100644
index 000000000000..76b0b41c7d50
--- /dev/null
+++ b/dev-python/logical-unification/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">logical-unification</remote-id>
+ <remote-id type="github">pythological/unification</remote-id>
+ </upstream>
+</pkgmetadata>