summaryrefslogtreecommitdiff
path: root/dev-python/locustio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-10 19:15:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-10 19:15:28 +0000
commitda6a52f691ef980bab92d003d5df8f463c623af8 (patch)
tree4d89e0d5915f8a3f57c8f9c17420ba3f7b44b7b2 /dev-python/locustio
parent80208fb578cf92cc308906660ca6d7860c6b2a1f (diff)
gentoo resync : 10.03.2018
Diffstat (limited to 'dev-python/locustio')
-rw-r--r--dev-python/locustio/Manifest2
-rw-r--r--dev-python/locustio/locustio-0.7.3-r1.ebuild (renamed from dev-python/locustio/locustio-0.7.3.ebuild)8
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/locustio/Manifest b/dev-python/locustio/Manifest
index 79fa0ed403ec..ba697aa475cd 100644
--- a/dev-python/locustio/Manifest
+++ b/dev-python/locustio/Manifest
@@ -1,3 +1,3 @@
DIST locustio-0.7.3.tar.gz 89300 BLAKE2B 4fba25ff54686a35f95de15766e38ffec0de24eae7e3100275dcdd25ef7dee1bccfbd1d31458a56f35a8ee5afaeea6c91ce40be2bdeb77ab7f9d663b378782b2 SHA512 fe2434691218be0749c0bf7c2c26b6b3172b7dd69898667441aa98a67ac5e5fbb513aebd27bd54c10f423da452f734c2d6ab7a52f4641755439cd3b81a82eee4
-EBUILD locustio-0.7.3.ebuild 747 BLAKE2B 071b1f0ded36ae272e1c457b0ce9c244e3c4a2abc553a274bfc42a8307d5f43bc0d99788d668da3481f0d943c7c591f830f9f48e2b91b5ebd1cf171972d9d1fe SHA512 45c7c5ec6e1c2590ac02e93ddf0c217d4c3a82ff4f960294437a25e2546ad1a2b815394f059fb2168b6af074ed8ae9d1a125dca93f7d4a6c51ed21577e965d64
+EBUILD locustio-0.7.3-r1.ebuild 879 BLAKE2B d8cc4b7942727db5d042db5b7d1125b659fb330ca02704c7b43915480d788caece3610bbade4bf6a886e345e23636030b3ca17b2fbee5f287eb8beb35cfaaf34 SHA512 43aab9e2fc7d4dd98bfaf6c116a388efe76bb4f72c0cb2be7b0e5f36498b2a0a65085d1c41d2ad076a798e96808a9854c5b2a05d77032b19783382b9dd9ed8eb
MISC metadata.xml 366 BLAKE2B a5b3f35409c984368b5fa0b7ce3713ead52af9bdb0dae2c18f4224e7c8b392eadf6350471ee4e928b7e39aa82ffdb8ca5b755562073430313357d1ff1e2c6573 SHA512 bfa39e9bf81a8fa9f1ac9fbd635daecbd3856a240bbeccaa8ee9afc632a21c07ccb2b5a6afd15008a828d2ca7fdacdc0825c2381636888a4f044f2ac0c5c311c
diff --git a/dev-python/locustio/locustio-0.7.3.ebuild b/dev-python/locustio/locustio-0.7.3-r1.ebuild
index 7892ab1e586c..4196e40e6d3b 100644
--- a/dev-python/locustio/locustio-0.7.3.ebuild
+++ b/dev-python/locustio/locustio-0.7.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -28,3 +28,9 @@ RDEPEND=">=dev-python/gevent-1.0.1[${PYTHON_USEDEP}]
python_test() {
esetup.py test
}
+
+python_prepare_all() {
+ # allow useage of renamed msgpack
+ sed -i '/^msgpack/d' setup.py || die
+ distutils-r1_python_prepare_all
+}