summaryrefslogtreecommitdiff
path: root/dev-python/locustio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /dev-python/locustio
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'dev-python/locustio')
-rw-r--r--dev-python/locustio/Manifest2
-rw-r--r--dev-python/locustio/locustio-0.9.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/locustio/Manifest b/dev-python/locustio/Manifest
index 3a595f3732d2..9ea011d15a33 100644
--- a/dev-python/locustio/Manifest
+++ b/dev-python/locustio/Manifest
@@ -1,3 +1,5 @@
DIST locustio-0.7.3.tar.gz 89300 BLAKE2B 4fba25ff54686a35f95de15766e38ffec0de24eae7e3100275dcdd25ef7dee1bccfbd1d31458a56f35a8ee5afaeea6c91ce40be2bdeb77ab7f9d663b378782b2 SHA512 fe2434691218be0749c0bf7c2c26b6b3172b7dd69898667441aa98a67ac5e5fbb513aebd27bd54c10f423da452f734c2d6ab7a52f4641755439cd3b81a82eee4
+DIST locustio-0.9.0.tar.gz 226870 BLAKE2B 595042f110f08ddb6bfdb9642f91448a0fb7229fcffcaa1392fdb351ac5106304e2743801134f4f87fab68b8f098122c88cdedb10566ed70035480ad69755e58 SHA512 9c51fa3af784b4b653fa5f55623ef8ec5eb6a94b8f3eacab97deeb7f5805a96b5467344d653a8916975f547d5a7a7ff63c83ffb8c289e805ccd5bb577aac04d7
EBUILD locustio-0.7.3-r1.ebuild 880 BLAKE2B c64055a454a07ea2f0ef3eff6912ca31ea1deb37206ce579450200994530408dd41c8d62b7a712825be219812bf68537c5b59ab6f9133c2efb948b73f8c61954 SHA512 4f8f48bccb9ceee50d735354c6f008797e7671717cdb046a9c81d74fb1ba7777452662df17cc5139a8bba73c761448f850d72f8159098fd1d0848467be26900e
+EBUILD locustio-0.9.0.ebuild 988 BLAKE2B 7990d28c814475060d94b9d5cb8b2ba4a8b69afe1face0aca5e032a4a2cc655c757204b1036afba5c70f163f4ac2f480df410fe0ceca0b0f5cf372a4e1cd82f8 SHA512 e48e44c1a72ce9bad95920bd3fdb33142ce688544921bc7c69a5b676f34ff72bd4c233fbdee30787d959cf12857c59d3403650900e1f052a6b01574a68679a1b
MISC metadata.xml 366 BLAKE2B a5b3f35409c984368b5fa0b7ce3713ead52af9bdb0dae2c18f4224e7c8b392eadf6350471ee4e928b7e39aa82ffdb8ca5b755562073430313357d1ff1e2c6573 SHA512 bfa39e9bf81a8fa9f1ac9fbd635daecbd3856a240bbeccaa8ee9afc632a21c07ccb2b5a6afd15008a828d2ca7fdacdc0825c2381636888a4f044f2ac0c5c311c
diff --git a/dev-python/locustio/locustio-0.9.0.ebuild b/dev-python/locustio/locustio-0.9.0.ebuild
new file mode 100644
index 000000000000..074ae16ed24d
--- /dev/null
+++ b/dev-python/locustio/locustio-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A python utility for doing easy, distributed load testing of a web site"
+HOMEPAGE="https://locust.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND=">=dev-python/gevent-1.2.2[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-16.0.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
+
+python_prepare_all() {
+ # allow useage of renamed msgpack
+ sed -i 's/"msgpack[^"]*"[, ]*//' setup.py || die
+ distutils-r1_python_prepare_all
+}