summaryrefslogtreecommitdiff
path: root/dev-python/lmfit/lmfit-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/lmfit/lmfit-1.0.2.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/lmfit/lmfit-1.0.2.ebuild')
-rw-r--r--dev-python/lmfit/lmfit-1.0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/lmfit/lmfit-1.0.2.ebuild b/dev-python/lmfit/lmfit-1.0.2.ebuild
new file mode 100644
index 000000000000..3e93970d9753
--- /dev/null
+++ b/dev-python/lmfit/lmfit-1.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
+HOMEPAGE="https://lmfit.github.io/lmfit-py/ https://github.com/lmfit/lmfit-py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/asteval-0.9.16[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+ >=dev-python/uncertainties-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.2[${PYTHON_USEDEP}]
+"
+# past from future needed for tests, bug #737978
+BDEPEND="${RDEPEND}
+ test? ( dev-python/future[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # numpy warning mismatch
+ tests/test_confidence.py::test_confidence_warnings
+ tests/test_model.py::TestUserDefiniedModel::test_extra_param_issues_warning
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}