summaryrefslogtreecommitdiff
path: root/dev-python/lmdb/lmdb-1.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/lmdb/lmdb-1.2.0-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/lmdb/lmdb-1.2.0-r1.ebuild')
-rw-r--r--dev-python/lmdb/lmdb-1.2.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/lmdb/lmdb-1.2.0-r1.ebuild b/dev-python/lmdb/lmdb-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..9c9fdaea7812
--- /dev/null
+++ b/dev-python/lmdb/lmdb-1.2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Lightning Database"
+HOMEPAGE="https://github.com/jnwatson/py-lmdb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="OPENLDAP"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-db/lmdb-0.9.28:=
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_compile() {
+ LMDB_FORCE_SYSTEM=1 distutils-r1_python_compile
+}
+
+python_test() {
+ epytest tests
+}
+
+python_install() {
+ # This is required when the CFFI extension is used (for PyPy3)
+ LMDB_FORCE_SYSTEM=1 distutils-r1_python_install
+}