summaryrefslogtreecommitdiff
path: root/dev-python/llvmlite/llvmlite-0.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/llvmlite/llvmlite-0.12.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/llvmlite/llvmlite-0.12.1.ebuild')
-rw-r--r--dev-python/llvmlite/llvmlite-0.12.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/llvmlite/llvmlite-0.12.1.ebuild b/dev-python/llvmlite/llvmlite-0.12.1.ebuild
new file mode 100644
index 000000000000..52f240ea76f0
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.12.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DISTUTILS_IN_SOURCE_BUILD="1"
+RESTRICT="test"
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="https://pypi.python.org/pypi/llvmlite"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+RDEPEND="
+ =sys-devel/llvm-3.7*
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3)
+ "
+DEPEND="${RDEPEND}
+ dev-util/cmake"
+
+python_prepare_all() {
+ sed -i -e 's/-flto$/-flto -fPIC/' \
+ -e 's/-static-libstdc++ //' ffi/Makefile.linux || die
+
+ # disable test using installed instance to read version info
+ sed -e 's:test_version:_&:' -i llvmlite/tests/test_binding.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m "llvmlite.tests" || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}