summaryrefslogtreecommitdiff
path: root/dev-python/lit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-24 10:45:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-24 10:45:40 +0000
commit1804d2ae908b26fe4e3d3a38646c7d6ffa733d92 (patch)
tree6f5cdff53cb2fde48a01817379124dc476b3742d /dev-python/lit
parent2fa0c8dbba3b2455531e5616eed64f2fe66cb58b (diff)
gentoo auto-resync : 24:01:2024 - 10:45:40
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/Manifest1
-rw-r--r--dev-python/lit/lit-19.0.0.9999.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/lit/Manifest b/dev-python/lit/Manifest
index 033f5f652a0b..51800c7774a5 100644
--- a/dev-python/lit/Manifest
+++ b/dev-python/lit/Manifest
@@ -14,4 +14,5 @@ EBUILD lit-18.0.0.9999.ebuild 961 BLAKE2B 4cf7d1fed4bc116054ce3c1b12784bd9626cbd
EBUILD lit-18.0.0_pre20240106.ebuild 961 BLAKE2B 0f4ca6b62575d436f2c8bec0dc8eae1f48f0d2a556dd9a36673ad5f5ef79c16665f285e459b6cf8aa926db4a2f337d0486be674bd73bb264ae9aa6d3b4968ee5 SHA512 229c1c3f97bc006bcd759c2aeb2eb94d7b0ea4d021b36ff06886d92916309c2d8e6907a527cb3a0adcca28a5d370d07162ee7119980cf86b9636bc94dc720c9a
EBUILD lit-18.0.0_pre20240113.ebuild 961 BLAKE2B 0f4ca6b62575d436f2c8bec0dc8eae1f48f0d2a556dd9a36673ad5f5ef79c16665f285e459b6cf8aa926db4a2f337d0486be674bd73bb264ae9aa6d3b4968ee5 SHA512 229c1c3f97bc006bcd759c2aeb2eb94d7b0ea4d021b36ff06886d92916309c2d8e6907a527cb3a0adcca28a5d370d07162ee7119980cf86b9636bc94dc720c9a
EBUILD lit-18.0.0_pre20240120.ebuild 961 BLAKE2B 0f4ca6b62575d436f2c8bec0dc8eae1f48f0d2a556dd9a36673ad5f5ef79c16665f285e459b6cf8aa926db4a2f337d0486be674bd73bb264ae9aa6d3b4968ee5 SHA512 229c1c3f97bc006bcd759c2aeb2eb94d7b0ea4d021b36ff06886d92916309c2d8e6907a527cb3a0adcca28a5d370d07162ee7119980cf86b9636bc94dc720c9a
+EBUILD lit-19.0.0.9999.ebuild 961 BLAKE2B 0f4ca6b62575d436f2c8bec0dc8eae1f48f0d2a556dd9a36673ad5f5ef79c16665f285e459b6cf8aa926db4a2f337d0486be674bd73bb264ae9aa6d3b4968ee5 SHA512 229c1c3f97bc006bcd759c2aeb2eb94d7b0ea4d021b36ff06886d92916309c2d8e6907a527cb3a0adcca28a5d370d07162ee7119980cf86b9636bc94dc720c9a
MISC metadata.xml 340 BLAKE2B c9ca851e49b4ab48c015686e983ec988f60c34ed0af77abd7bc03d046002f79f74b9b463ecb97db89f2230c1593af7acdaf6651fc51fed4aa92a459d07aabf18 SHA512 3fe8262ce6b971364162fbdbac3b02bf02f0a64896c8a2564e2a2998bd6e6bc74463bf9104e3f4ffaa9f5c1a16c877fc864b8a4f056ca0022f741799bc00f217
diff --git a/dev-python/lit/lit-19.0.0.9999.ebuild b/dev-python/lit/lit-19.0.0.9999.ebuild
new file mode 100644
index 000000000000..3d0315962098
--- /dev/null
+++ b/dev-python/lit/lit-19.0.0.9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm
+ )
+"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ # flaky test
+ # https://github.com/llvm/llvm-project/issues/72022
+ rm tests/progress-bar.py || die
+
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}