summaryrefslogtreecommitdiff
path: root/dev-python/lit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /dev-python/lit
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/Manifest1
-rw-r--r--dev-python/lit/lit-8.0.9999.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/lit/Manifest b/dev-python/lit/Manifest
index 9f7cde337b98..dfc86e3b42f6 100644
--- a/dev-python/lit/Manifest
+++ b/dev-python/lit/Manifest
@@ -9,5 +9,6 @@ EBUILD lit-5.0.2.ebuild 904 BLAKE2B 74ccf4ce59c6aba63fec1f0dfed1e49bf751abf8cf61
EBUILD lit-6.0.1.ebuild 1014 BLAKE2B 549c00ba1da9265ef26ea04d574d139f1fbab99f79ed60f270ff960f940df4507376fe31d48776241ecf4a4cb84f134abec61c000a27756ba057083527cd6607 SHA512 729a2b96a49758b18e59ec9df38ddff9890953283185cbae0abeef1cf4f11c2680485f26ffa70a85b326a389a3230e459700366b06f6bcee5a4be9854afeef62
EBUILD lit-7.0.1.ebuild 1017 BLAKE2B f901810a470fdf95f71bb19e6be4a1321e7abe84054bb529541750dea272ffb33c4eda1e131d2b9984225f25d28036876b56d8bb0c9a76a623f7d678098b4932 SHA512 ddb2c555b404d838b4717506a3bdbd40fe5a8d1490175ff65c12601ab1805882b48eb585a1ea1ed761638469145d1e5ecd0696bb01c4ff3d83c5e817a99d5c9f
EBUILD lit-7.0.9999.ebuild 963 BLAKE2B afea4754348b5b93f93ef1723974f218ccf92bcceb342ba5f453e8d82399358689b4bb30d04e65e63de761ccc92bd2c776d6233c618a12abaf4fda1a770974ff SHA512 dab5c3d116a590f677a9d3773d5652e7a676d26a4477ed10a4f8248f93297881ec1bd9cd6fbca6c06546d0926bdd5aedc9f478736550114bdb777c61ccaf5bca
+EBUILD lit-8.0.9999.ebuild 960 BLAKE2B 3c1be7024e1f32c6c1c73e03f6a909d1f16cbc0750a4dec454806dc39c2fadf32f006045cbf71272a0a35c471a68daa142e96683610573627d82b81fdbc7751c SHA512 d1d2099ef259dc024f91074b5fe5cc6f9d1fa834f8922823dad0b67c8cb92f454e9694aee0b325762ad6aac2ca1b47c497e25027c1c82a186bf937b56c2d95cf
EBUILD lit-9999.ebuild 938 BLAKE2B fb5fe20c62d06e44e847f6e9f16429e9814d2872281295eb12ea25baf2448be889ec3bac37ec4350971b44c6785aafe9795fd68cbfda1b2cb299f41f28a254fd SHA512 a21a7a2935e8d8c82f319bf65e1b01e135448c2d342baea28b05451f4f9de938b52d3a8e63d544ec35cf4e7ae7bc9bf432eea3f4a44d044631c9ae7ea6fbfdcf
MISC metadata.xml 216 BLAKE2B fe5e49887842aa513fbf1f2e09bed09a884d531fd21bdaeb2d389e8bf590b6c0e7063f0af98f66e2db129308ab0f0804ba327c3c752bbb4c900c59ac109d99aa SHA512 3485598147c953e72e1785693a489a7e7d73d59620b76054db9c0ce95d8bfa0e8ffec29da7f7a9d73a32e5b77eac07ca3306c56a972dc57fd89d477edaebf3d5
diff --git a/dev-python/lit/lit-8.0.9999.ebuild b/dev-python/lit/lit-8.0.9999.ebuild
new file mode 100644
index 000000000000..27b4c0f19d5c
--- /dev/null
+++ b/dev-python/lit/lit-8.0.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+inherit distutils-r1 git-r3 multiprocessing
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+EGIT_BRANCH="release_80"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${P}/utils/lit
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/lit
+}
+
+python_test() {
+ ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
+ -vv tests || die
+}