summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-16.0.0_pre20221126.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 13:14:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 13:14:43 +0000
commit7de40ae3e1ba40671bc9aac9ebbf3f42952a036b (patch)
tree1bca877e82a542b8d0809d9de07a59ae67941c07 /dev-python/lit/lit-16.0.0_pre20221126.ebuild
parentfd3ff6e6efb0d3cf8b899956e7b48df4e2ac9615 (diff)
gentoo auto-resync : 26:11:2022 - 13:14:42
Diffstat (limited to 'dev-python/lit/lit-16.0.0_pre20221126.ebuild')
-rw-r--r--dev-python/lit/lit-16.0.0_pre20221126.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/lit/lit-16.0.0_pre20221126.ebuild b/dev-python/lit/lit-16.0.0_pre20221126.ebuild
new file mode 100644
index 000000000000..8ace6ca8b915
--- /dev/null
+++ b/dev-python/lit/lit-16.0.0_pre20221126.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm
+ )
+"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}