summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-14.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/lit/lit-14.0.0.9999.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/lit/lit-14.0.0.9999.ebuild')
-rw-r--r--dev-python/lit/lit-14.0.0.9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/lit/lit-14.0.0.9999.ebuild b/dev-python/lit/lit-14.0.0.9999.ebuild
index 37168fbde9bd..89c5315a5acb 100644
--- a/dev-python/lit/lit-14.0.0.9999.ebuild
+++ b/dev-python/lit/lit-14.0.0.9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 llvm.org
@@ -20,7 +21,8 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm )"
+ sys-devel/llvm
+ )"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals