summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/line_profiler
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest3
-rw-r--r--dev-python/line_profiler/files/line_profiler-3.0.2-python3_9.patch35
-rw-r--r--dev-python/line_profiler/line_profiler-3.0.2.ebuild6
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index d91daf9ea415..cdd317d4ab44 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,3 +1,4 @@
+AUX line_profiler-3.0.2-python3_9.patch 1058 BLAKE2B 0d0bb5c9e845d8d30ebec532108fdd0241710494ac22e675f36f1ffed2ef2736d3adf35b32f9efabe1f6e70d986a332507283ba22dede99182573ce158809082 SHA512 448d629790b934f3edc7a3e40d18d880f289d77fe9530cbe252b8b01e8473effd75eaf3ae1c0c26427c27c7193176932e83a69fbc64c2d6107366a5ba974dc87
DIST line_profiler-3.0.2.tar.gz 45185 BLAKE2B 04e617cc7b6c9686192281ab1cdfdef2cfc6ce3c7aa6b9962ed2369620618af8835b93bafe89f8d1288b45d4120d71f728ec577d5c5d035699c2d7a49d6be7c1 SHA512 9a5d1821c02fc063081854ba98a17eca21af65d5aecf4ce32c67806d31bf0c936291a30409845ce6f94211cdaaaf0859ab5e2b437e1a086fd4f60fc2a0fd2742
-EBUILD line_profiler-3.0.2.ebuild 1152 BLAKE2B dbfd004c68d715d9cf2b6f6f863e10a0a8eb01b34ed350301804a07fb17a792196977dc7ab39fce0766b7dfcd27e5b08f9998671ce0548e71e45521bcae35acf SHA512 f22c83187b2f49488706eddd1a02cb6516100bbf9b2d2a8d6514f756540a5425bc72829ea6ac8a0c25afbfe11ad80f02e2c60c5bde3aa1b37ad0b3ae8dee90c2
+EBUILD line_profiler-3.0.2.ebuild 1200 BLAKE2B 33c6b42561b262ec5d8d000814dd35452d4d89b0dbb89b49ccde693d0663dc085f06a7c735b166d2783bfff8d88c649192455a820022d304290192af5053407e SHA512 53f71b28d179f040ab69a990dfe280cf47c46a1f3b0ec40f89373ddac4d924ab8e766dc20fccc4b859c3492ff4393146854d5d11a94d873ddd6bdbab5dba8312
MISC metadata.xml 691 BLAKE2B 7cf7f3e2a82470d3d3423e203fe1db3ab849502af636e6e36664937738cfb179960c8dbaa2628550e0490f71dd3baec74b083e4341122144cd1b8a6a6c503bdf SHA512 9430cfef2807664446522f0401645522714eac92f990d9c9b4568d3362a26250a3059a386c35e875e2e186206a6401d87b09ad6d66b3d5accc11bc40f73901b7
diff --git a/dev-python/line_profiler/files/line_profiler-3.0.2-python3_9.patch b/dev-python/line_profiler/files/line_profiler-3.0.2-python3_9.patch
new file mode 100644
index 000000000000..74b0677bc70a
--- /dev/null
+++ b/dev-python/line_profiler/files/line_profiler-3.0.2-python3_9.patch
@@ -0,0 +1,35 @@
+From f40a6e102d3c4808155af601ddba7733e597e604 Mon Sep 17 00:00:00 2001
+From: Stefano Rivera <stefano@rivera.za.net>
+Date: Thu, 15 Oct 2020 22:44:50 -0700
+Subject: [PATCH] Python 3.9 dropped gettimeofday configure checks
+
+Upstream status: Accepted [https://github.com/pyutils/line_profiler/pull/31}
+Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
+
+diff --git a/line_profiler/timers.c b/line_profiler/timers.c
+index ae01060..e8ee6c6 100644
+--- a/line_profiler/timers.c
++++ b/line_profiler/timers.c
+@@ -32,10 +32,6 @@ hpTimerUnit(void)
+
+ #else /* !MS_WINDOWS */
+
+-#ifndef HAVE_GETTIMEOFDAY
+-#error "This module requires gettimeofday() on non-Windows platforms!"
+-#endif
+-
+ #if (defined(PYOS_OS2) && defined(PYCC_GCC))
+ #include <sys/time.h>
+ #else
+@@ -48,11 +44,7 @@ hpTimer(void)
+ {
+ struct timeval tv;
+ PY_LONG_LONG ret;
+-#ifdef GETTIMEOFDAY_NO_TZ
+- gettimeofday(&tv);
+-#else
+ gettimeofday(&tv, (struct timezone *)NULL);
+-#endif
+ ret = tv.tv_sec;
+ ret = ret * 1000000 + tv.tv_usec;
+ return ret;
diff --git a/dev-python/line_profiler/line_profiler-3.0.2.ebuild b/dev-python/line_profiler/line_profiler-3.0.2.ebuild
index a48003e8777a..5c5578115921 100644
--- a/dev-python/line_profiler/line_profiler-3.0.2.ebuild
+++ b/dev-python/line_profiler/line_profiler-3.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -26,6 +26,10 @@ DEPEND="test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/ubelt[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/${P}-python3_9.patch
+)
+
distutils_enable_tests pytest
python_test() {