summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/line_profiler
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest6
-rw-r--r--dev-python/line_profiler/line_profiler-2.0.ebuild30
-rw-r--r--dev-python/line_profiler/line_profiler-2.1.2.ebuild30
-rw-r--r--dev-python/line_profiler/line_profiler-9999.ebuild27
-rw-r--r--dev-python/line_profiler/metadata.xml26
5 files changed, 119 insertions, 0 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
new file mode 100644
index 000000000000..626d01819110
--- /dev/null
+++ b/dev-python/line_profiler/Manifest
@@ -0,0 +1,6 @@
+DIST line_profiler-2.0.tar.gz 68478 BLAKE2B fb814b251e8f18a51e65297e57523b85c55b4060444c42d99801aa88c8ee0279abf14def6ecd5a9b09550e46e2d27b3ec809b1333725b00de64b58f117c76ed7 SHA512 c0335fc69fb47c150fa5555af4f7fdf4b172ca12ee6512e04ba854c4a81f3e6ee5594e484d11c8ea7e9e8048e3f3b8661db52332d4ac645195a0e050acea4ecb
+DIST line_profiler-2.1.2.tar.gz 83131 BLAKE2B 0f61d7dbab24988a50c1c0a9dce528cf792ca53b5f4c60f00fd9dabfd3d3e109f2d245867bc1ebb8294fb84343907e3593c416341ea1b0d7ae626cda8a3218d3 SHA512 625a585915d338fe8ef2f37c5b5bc024f769a623380b85725bcf33686e4cc62a211c2e91552e093dee940367b0d2ad306c5cbe7f1e8f1574eb731d128b8e22bd
+EBUILD line_profiler-2.0.ebuild 671 BLAKE2B b15f6a8aea97da13be021fcdc6bd3d4513e1d5645e30ae70f3c71ccdb9ecc9612d9f09ecdfee77e4a2cf8900090360f7f127612babb13aaa1218d15de33240d8 SHA512 033d96c26db7b06f2c8e937f005d7e63042efa538be3871ed9f8b211aee58db5d47075160c79653fc45dbdc43b8b5a692395015f260f9e57a1a05277bdffcacd
+EBUILD line_profiler-2.1.2.ebuild 665 BLAKE2B 0e4a8c4712096f0e708ad35e60f8ab88415ec3f68de2a75e7db2288b1cde44c727202366a6cec3d3856b06dd5178c206de4645b0fbea139af92aa4c403729b18 SHA512 7d274a5755f8f2370fbdbf7f4a79fa66bcb64ea268a023785864a794fc5ca19e484d5b2248fcbe534188b0bbc52bfd69bc8c7e6e65dfed9eeffebf13418d849c
+EBUILD line_profiler-9999.ebuild 584 BLAKE2B c78d372870ede31f3173da1a0ac961acbf265ec4d1dd4e53b9e0142cb13e2d82d2b0107581ba3b8f542b231ce1047342b60438fd789f34e7409013159a3982e9 SHA512 37315fe17913c84f589ad259296a3d7df23f7f03ddc447370c7b42881f8194b9d154bde87d5cee7ecf20585179480300ce19000eb433d8493ab45be3e3a88f6d
+MISC metadata.xml 948 BLAKE2B 98a4791e0201690c210cd9460be2c17378a360c9dce1502f3293e26468f94aa0c20b28844e41e6e43acd049152057726b4e12f4f7b2a99e0ad38a73296d12403 SHA512 bc38bde3c69ae03dc884b60a55eaaa0b039119d31a552083d22baca047f102f7519606ca2219578b3a9ed3dcf40a68f6aa0dc8508e7258f0a6a993b2ab7a0461
diff --git a/dev-python/line_profiler/line_profiler-2.0.ebuild b/dev-python/line_profiler/line_profiler-2.0.ebuild
new file mode 100644
index 000000000000..deafa2e96f54
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/rkern/line_profiler
+ https://pypi.org/project/line_profiler/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v "${S}"/tests/ \
+ || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/line_profiler/line_profiler-2.1.2.ebuild b/dev-python/line_profiler/line_profiler-2.1.2.ebuild
new file mode 100644
index 000000000000..1928a30d51d9
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-2.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/rkern/line_profiler
+ https://pypi.org/project/line_profiler/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v "${S}"/tests/ \
+ || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/line_profiler/line_profiler-9999.ebuild b/dev-python/line_profiler/line_profiler-9999.ebuild
new file mode 100644
index 000000000000..6db2d5c980f7
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="https://github.com/rkern/line_profiler"
+EGIT_REPO_URI="https://github.com/rkern/${PN}.git"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ "${PYTHON}" -m unittest discover -v "${S}"/tests/ \
+ || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/line_profiler/metadata.xml b/dev-python/line_profiler/metadata.xml
new file mode 100644
index 000000000000..646d50c3d2b7
--- /dev/null
+++ b/dev-python/line_profiler/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <longdescription>
+ line_profiler is a module for doing line-by-line profiling of
+ functions. kernprof is a convenient script for running either
+ line_profiler or the Python standard library's cProfile or profile
+ modules, depending on what is available.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">line_profiler</remote-id>
+ <remote-id type="github">rkern/line_profiler</remote-id>
+ </upstream>
+</pkgmetadata>