summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler/line_profiler-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/line_profiler/line_profiler-3.3.0.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/line_profiler/line_profiler-3.3.0.ebuild')
-rw-r--r--dev-python/line_profiler/line_profiler-3.3.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/line_profiler/line_profiler-3.3.0.ebuild b/dev-python/line_profiler/line_profiler-3.3.0.ebuild
new file mode 100644
index 000000000000..1f06702ad61f
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-3.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+# force it to match scikit-build
+CMAKE_MAKEFILE_GENERATOR=ninja
+
+inherit cmake distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="https://github.com/pyutils/line_profiler/"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+# technically, the package claims to support non-scikit-build build
+# but it's clearly unmaintained and broken at the moment
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/scikit-build[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd tests || die
+ epytest
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}