summaryrefslogtreecommitdiff
path: root/dev-python/line-profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-22 21:47:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-22 21:47:11 +0100
commit9368ace94caa5cdda868a0dbb7c75a3fc7a2b911 (patch)
treea9a5e87e053b6853c703732ad8050bd895efc1ea /dev-python/line-profiler
parentc1d361b300cff921a04bd9ae2f800bf8914559eb (diff)
gentoo auto-resync : 22:08:2023 - 21:47:11
Diffstat (limited to 'dev-python/line-profiler')
-rw-r--r--dev-python/line-profiler/Manifest5
-rw-r--r--dev-python/line-profiler/line-profiler-4.1.0.ebuild47
-rw-r--r--dev-python/line-profiler/line-profiler-4.1.1.ebuild47
-rw-r--r--dev-python/line-profiler/metadata.xml21
4 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/line-profiler/Manifest b/dev-python/line-profiler/Manifest
new file mode 100644
index 000000000000..afb05709e3fa
--- /dev/null
+++ b/dev-python/line-profiler/Manifest
@@ -0,0 +1,5 @@
+DIST line_profiler-4.1.0.gh.tar.gz 99250 BLAKE2B aa875dfb8cdbaaa701a03d10fd904504825d58e551dddabddbe0abca777a584bae5c37f4b3ab80d10dc869138106d70c3ff243a7d28e570983427520dd4ee569 SHA512 08e0395b80f8c111725227abea7e8b2d6864da840a0a6f4de5eb71a2df2ae78871c930897b49d75a184973c1ce21d61106817bd0b8d4556462f0505bbbc21fe1
+DIST line_profiler-4.1.1.gh.tar.gz 99299 BLAKE2B fa5e1588167d4e1b451ebeef6bd625c25053e0370268fb435ae6cd72e5e56c0a6252cf3970d8e2bd7952bf61d16662128f68d5106aee8190bc9fe65d3180cf2d SHA512 4170d1b89b3b8e4bbeaf9ce145f67214ef133ea87d6c02d59f5da0ddab30fc14a89d11bbd749e9707c4a0654db23b22eef7f73749ee3023544835f562da62762
+EBUILD line-profiler-4.1.0.ebuild 898 BLAKE2B a4f96f29c93b90a50b6165b797205146f47beca9ddc06bb65d52de142ed15ea773f19db410122507bd520b671c6e8b6e7cff3b1fb69bb2529e9d592cf2e7c03d SHA512 9ae3cd3af7e09103db4097336fa7f32d22fa2237be32f2bda1e7260614dc9e56d9bbf8f5c5d30698da70bbf7a70dbee78ea527614ea11260b56f11be74a4480d
+EBUILD line-profiler-4.1.1.ebuild 898 BLAKE2B a4f96f29c93b90a50b6165b797205146f47beca9ddc06bb65d52de142ed15ea773f19db410122507bd520b671c6e8b6e7cff3b1fb69bb2529e9d592cf2e7c03d SHA512 9ae3cd3af7e09103db4097336fa7f32d22fa2237be32f2bda1e7260614dc9e56d9bbf8f5c5d30698da70bbf7a70dbee78ea527614ea11260b56f11be74a4480d
+MISC metadata.xml 775 BLAKE2B de65859e8267b3385a49550fa47ee33d0f428e5833a59d8224aa4eb2b0251841c58acc1ca446ef1b13d258c5b861045f042f7ca13e8a27db7253f4202753c607 SHA512 22a65b06d81651455ecd9690bc5c6d4c87858bf912eb491dde16650a3692408ca95a1d42d82204e67509f4e685651b5b2b2537b5db0891b7ca6933bddd616d16
diff --git a/dev-python/line-profiler/line-profiler-4.1.0.ebuild b/dev-python/line-profiler/line-profiler-4.1.0.ebuild
new file mode 100644
index 000000000000..5ffe92f3463f
--- /dev/null
+++ b/dev-python/line-profiler/line-profiler-4.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=line_profiler-${PV}
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+ https://pypi.org/project/line-profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+# <cython-3: https://bugs.gentoo.org/911735
+BDEPEND="
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export LINE_PROFILER_BUILD_METHOD=cython
+
+python_test() {
+ cd tests || die
+ epytest
+}
diff --git a/dev-python/line-profiler/line-profiler-4.1.1.ebuild b/dev-python/line-profiler/line-profiler-4.1.1.ebuild
new file mode 100644
index 000000000000..5ffe92f3463f
--- /dev/null
+++ b/dev-python/line-profiler/line-profiler-4.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=line_profiler-${PV}
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+ https://pypi.org/project/line-profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+# <cython-3: https://bugs.gentoo.org/911735
+BDEPEND="
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export LINE_PROFILER_BUILD_METHOD=cython
+
+python_test() {
+ cd tests || die
+ epytest
+}
diff --git a/dev-python/line-profiler/metadata.xml b/dev-python/line-profiler/metadata.xml
new file mode 100644
index 000000000000..1b582c391cb4
--- /dev/null
+++ b/dev-python/line-profiler/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ line_profiler is a module for doing line-by-line profiling of
+ functions. kernprof is a convenient script for running either
+ line_profiler or the Python standard library's cProfile or profile
+ modules, depending on what is available.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">line-profiler</remote-id>
+ <remote-id type="github">pyutils/line_profiler</remote-id>
+ </upstream>
+</pkgmetadata>