summaryrefslogtreecommitdiff
path: root/dev-python/libtmux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-02 03:27:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-02 03:27:54 +0100
commitdef28ad1de5a6853465d7ff8f626cda6a774cd9e (patch)
tree09d192ed59036d9875ed2b21aef62035a4727f38 /dev-python/libtmux
parenteba9df5b84c2fffc30cc3f300880000a60e38042 (diff)
gentoo auto-resync : 02:06:2023 - 03:27:54
Diffstat (limited to 'dev-python/libtmux')
-rw-r--r--dev-python/libtmux/Manifest2
-rw-r--r--dev-python/libtmux/libtmux-0.22.1.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index 5d74f442c960..074d964265d4 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -1,3 +1,5 @@
DIST libtmux-0.21.0.gh.tar.gz 267484 BLAKE2B 36d7af1bd90ff5a9639587d79f49643eec1e218d3b1839f5febdd9b6b402886e577b15c920cf458ecb14b4e6d532955b6d71ecf932060e6f8ba32193d6bb0162 SHA512 27000581396d79665e34b67a9e59bf639ca0fbd855ada9648750750e41e732cdcde15a05c6548993f08a8637783ddb478de24b75d5c18a198541c36b4b08b9cc
+DIST libtmux-0.22.1.gh.tar.gz 266173 BLAKE2B 743d43fcebfb0058c9ff13f0fb9ad811403f85bf80dd68dbeead86fe079b4176db15c9bf0a8dd48fae67cb9fa968633595a51e6fcf6091bff54df911d2dd17bf SHA512 f056ecbf793cd90bb60d50252c78eb67a8312eb3eda92d68ff69ed85270f23c9d4489789438fb9d228600320a2afb64a29a70c00a415604b65079167381c46d6
EBUILD libtmux-0.21.0.ebuild 1224 BLAKE2B 0c19dc33639ef451cfe4659aab6b3b1e38d96cb6899f6dbb85aa655a99010be3174ad43c7c7522d3c2d8e597e789048ae8feddc03836d4ab60fd9c5333c9b665 SHA512 9c9e4c7aa82223e54b12bfdd3c088954221f5794723d4766988654d99e3a349eb1928c664cd590021f1a30fc3a854e0811e8f993ffe431394c0fee3839a54b19
+EBUILD libtmux-0.22.1.ebuild 1226 BLAKE2B 33869818384b647487e2b595316882f800a75a819ae93e1744273347f1b020cb96d03d83546ecb48b76f1c4627335db6d84b46e6aad92eced8a8cc2bd3121cba SHA512 ff6dd7967eb642106ef4a5ec353d405b814df2c7d3a90d31b085bb3789155cfe0b92704268c8b3d5a82dde6dbcf700d71182d5b3f63ba7ae346d9f76d3ba769e
MISC metadata.xml 403 BLAKE2B 68af7251349c8999bbdbfb7b55ca4632f8752468d7e478fd985097af86d00afe93b231667a25e3c997a3bc86b708d4e6d6ef5c35a783871cdc83519fc1db1ab1 SHA512 2a88df695e94f1da966bb72f7e90d00f2e343e40fe1924837f8c087dfc9a9a84fe0b2909a98f2f41ba72f6ba01796888a80cbac3f1bf9f05984a06385037d977
diff --git a/dev-python/libtmux/libtmux-0.22.1.ebuild b/dev-python/libtmux/libtmux-0.22.1.ebuild
new file mode 100644
index 000000000000..499498389f30
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.22.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API for tmux"
+HOMEPAGE="
+ https://libtmux.git-pull.com/
+ https://github.com/tmux-python/libtmux/
+ https://pypi.org/project/libtmux/
+"
+SRC_URI="
+ https://github.com/tmux-python/libtmux/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ libtmux/pane.py::libtmux.pane.Pane.send_keys
+)
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ sed -e '/addopts/s:--doctest-docutils-modules::' \
+ -e '/README\.md/d' \
+ -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}