summaryrefslogtreecommitdiff
path: root/dev-python/libtmux/libtmux-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /dev-python/libtmux/libtmux-0.8.1.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'dev-python/libtmux/libtmux-0.8.1.ebuild')
-rw-r--r--dev-python/libtmux/libtmux-0.8.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/libtmux/libtmux-0.8.1.ebuild b/dev-python/libtmux/libtmux-0.8.1.ebuild
new file mode 100644
index 000000000000..517f2c71e586
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${BDEPEND}
+ test? (
+ >=dev-python/pytest-4.3.1[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+RDEPEND="app-misc/tmux"
+
+# tests aren't included in the dist tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}