summaryrefslogtreecommitdiff
path: root/dev-python/libnacl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-05 09:19:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-05 09:19:42 +0100
commita14be3350a832e70959d0b2386bc43c3b95f82e1 (patch)
treea0bd34e3c1e8ca9489d08f257a5f29171d4bfe7f /dev-python/libnacl
parent9d86a2177f8ea7e726ba388e4ee28007def4d4ac (diff)
gentoo auto-resync : 05:08:2023 - 09:19:42
Diffstat (limited to 'dev-python/libnacl')
-rw-r--r--dev-python/libnacl/Manifest2
-rw-r--r--dev-python/libnacl/libnacl-1.9.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/libnacl/Manifest b/dev-python/libnacl/Manifest
index d37d4c436fda..44bc64f24e1b 100644
--- a/dev-python/libnacl/Manifest
+++ b/dev-python/libnacl/Manifest
@@ -1,3 +1,5 @@
DIST libnacl-1.8.0.gh.tar.gz 43351 BLAKE2B 4ba0ebcb50755d80418ffe7238c65d9309954cb2a0eac61937c488144b56093f3fcd87f0bf22a290c7b415c70cb781fbf7a2c608863d43694230fe34b3ad418e SHA512 7a39d646083591782691c4d58fd4d743b385ee553bcc4c4741707a237fa3b1213629b5070390526175bdfe8436859aa7711779ff8b22a981227edb30b94e82d6
+DIST libnacl-1.9.0.gh.tar.gz 43752 BLAKE2B 4a604958aeb9c4b26351b74fa3452b72b7e822c9ea28f4a070464568f1eed184615f0ad5624a2838bf055cf221a9a0f493419b16f2bf2be26c608b396d3f234c SHA512 1c1011f218864f4eab6a985a957f7ec5b8a227ed107ab336a0bc076be10bae6d598f3e81f3a20177e81f25f93c36b23118f515b98f87e11b1f727cae3db1e267
EBUILD libnacl-1.8.0.ebuild 782 BLAKE2B 0216680717e3b0c294a14d763d97140d21a0b517af904d253575f35db99bde46b41bb2397c596ce4c788d8d14f586693e7cbc1ff7463a05df2cddacac7362dec SHA512 e8aef74e8f4731daf70e96ade4bad41b75503b96a039ebe7258c6b92e7b653eb298f52449ae14409126b1569a200693e194af7083e3af365364dae3674a181d7
+EBUILD libnacl-1.9.0.ebuild 716 BLAKE2B bc3a906d9e8d7ef6877d24c0eb51b24eeadf9fbe26227c1cce7e067f7b6661e65fbc172191c1eab8904151ba2051c63199cc52382dd8b75d87fdbd1235e7300f SHA512 e5a5fb176e113cd6eaba994186b39231920f4e54bb0dbeb2ff1ad87072a267b5e6253b3fff5cd8b6578e1a7378d76fcb89415097cc5cc21172274e2cf541d7c1
MISC metadata.xml 496 BLAKE2B a01f3bd084333c8a79bae53afa580adbdde4154656a6a88d6a4b0714e0c752a9ec73677151e1f940abd040426f69dd30214909fc5c318fd13bc29087c6d36113 SHA512 56b52d188839a79fcdf0a341d18e7d0625fd05c48f2b376b164483999198ffd3b51328191462dc81ea29644cfa0025c00a7c8091041e16b1347cdab16b2b78ca
diff --git a/dev-python/libnacl/libnacl-1.9.0.ebuild b/dev-python/libnacl/libnacl-1.9.0.ebuild
new file mode 100644
index 000000000000..62aad69145c6
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="
+ https://libnacl.readthedocs.io/
+ https://github.com/saltstack/libnacl/
+ https://pypi.org/project/libnacl/
+"
+SRC_URI="
+ https://github.com/saltstack/libnacl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/libsodium
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -p 'test_*.py' tests/ ||
+ die "Tests failed with ${EPYTHON}"
+}