summaryrefslogtreecommitdiff
path: root/dev-python/libnacl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/libnacl
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/libnacl')
-rw-r--r--dev-python/libnacl/Manifest5
-rw-r--r--dev-python/libnacl/files/libnacl-1.7.2-32bit.patch25
-rw-r--r--dev-python/libnacl/libnacl-1.7.2-r1.ebuild26
-rw-r--r--dev-python/libnacl/libnacl-1.8.0.ebuild39
4 files changed, 41 insertions, 54 deletions
diff --git a/dev-python/libnacl/Manifest b/dev-python/libnacl/Manifest
index 70667019beae..06491a95e975 100644
--- a/dev-python/libnacl/Manifest
+++ b/dev-python/libnacl/Manifest
@@ -1,4 +1,3 @@
-AUX libnacl-1.7.2-32bit.patch 890 BLAKE2B 40afbe3e71b550da59b9c26c2834ea72b151d847605572bec3b149edf714125698014a8e30c2e8d9c49cca489564ccf5fbdf0f7033caea528ee588716e222a2b SHA512 8ee93b8dcb23228b3f294a947a54f49afd9fc4dc9207fe999ca7349868cfc05741ea8cab004087c3f0544436fb445ea3f513b574076f6350b2390415a3be7426
-DIST libnacl-1.7.2.tar.gz 43343 BLAKE2B 4f7d03661e1385033c51821bf673c81ced11a1523b371ec7da42ed9cf75bdaadee1e679059dfae85871530652b5fea80bfb91c19a8a1eefb4ecf1b8661f11e19 SHA512 a4efbf73f73d9493ac365efa5a5bd6481f85ce4c880ad236bbf7478090bdea857e78e33e445c4e467d2a2032040863b835f32f9a942d2f1e467015bd76b0d469
-EBUILD libnacl-1.7.2-r1.ebuild 640 BLAKE2B 6ae693e843c14124d826936beb862e66c762fd1868b7eb37e09d9b68c964ee1f44366135f12d9d41fbc57a24a4a845c425711f5d38c4cbb1267c5e678ffe81bc SHA512 f1c8d48884817127620180bbd16c9ed001976343d52e94781d0e2a9f8f07a0952c22feeb65c2643f8b11c6528cc5dea1a82a3ad307980536431ad196fcc7f5ce
+DIST libnacl-1.8.0.gh.tar.gz 43351 BLAKE2B 4ba0ebcb50755d80418ffe7238c65d9309954cb2a0eac61937c488144b56093f3fcd87f0bf22a290c7b415c70cb781fbf7a2c608863d43694230fe34b3ad418e SHA512 7a39d646083591782691c4d58fd4d743b385ee553bcc4c4741707a237fa3b1213629b5070390526175bdfe8436859aa7711779ff8b22a981227edb30b94e82d6
+EBUILD libnacl-1.8.0.ebuild 782 BLAKE2B 85b0d6f3fde620c45258129e8612074071179d1115c51b42db9c8765ab97100826009fb0c6e25386a75a7abfeeb2e1fef1228f29e61057072063c4eb5a614946 SHA512 5da125ad6b158dc480438f5196b278b678cea8606e7b83c3a643a30a98ca409b0e70760a5497c7fda05c3500e992cfdbf1ca87ff0ed90157a8d20ac8c6f1c3f7
MISC metadata.xml 496 BLAKE2B a01f3bd084333c8a79bae53afa580adbdde4154656a6a88d6a4b0714e0c752a9ec73677151e1f940abd040426f69dd30214909fc5c318fd13bc29087c6d36113 SHA512 56b52d188839a79fcdf0a341d18e7d0625fd05c48f2b376b164483999198ffd3b51328191462dc81ea29644cfa0025c00a7c8091041e16b1347cdab16b2b78ca
diff --git a/dev-python/libnacl/files/libnacl-1.7.2-32bit.patch b/dev-python/libnacl/files/libnacl-1.7.2-32bit.patch
deleted file mode 100644
index f8a06d27949a..000000000000
--- a/dev-python/libnacl/files/libnacl-1.7.2-32bit.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From f1567460f2d07822f2125778a55bf90b74ef807f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Mon, 12 Apr 2021 15:10:09 +0200
-Subject: [PATCH] Fix crypto_kdf_derive_from_key() on 32-bit platforms
-
----
- libnacl/__init__.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libnacl/__init__.py b/libnacl/__init__.py
-index 1aa722a..7649013 100644
---- a/libnacl/__init__.py
-+++ b/libnacl/__init__.py
-@@ -1180,7 +1180,7 @@ def crypto_kdf_derive_from_key(subkey_size, subkey_id, context, master_key):
- '''
- size = int(subkey_size)
- buf = ctypes.create_string_buffer(size)
-- nacl.crypto_kdf_derive_from_key(buf, subkey_size, subkey_id, context, master_key)
-+ nacl.crypto_kdf_derive_from_key(buf, subkey_size, ctypes.c_ulonglong(subkey_id), context, master_key)
- return buf.raw
-
- # Key Exchange API
---
-2.31.1
-
diff --git a/dev-python/libnacl/libnacl-1.7.2-r1.ebuild b/dev-python/libnacl/libnacl-1.7.2-r1.ebuild
deleted file mode 100644
index e5cc5e684c1e..000000000000
--- a/dev-python/libnacl/libnacl-1.7.2-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python ctypes wrapper for libsodium"
-HOMEPAGE="https://libnacl.readthedocs.org/"
-SRC_URI="https://github.com/saltstack/libnacl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="dev-libs/libsodium"
-BDEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/libnacl-1.7.2-32bit.patch
-)
-
-python_test() {
- "${EPYTHON}" -m unittest discover -v -p 'test_*.py' tests/ || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/libnacl/libnacl-1.8.0.ebuild b/dev-python/libnacl/libnacl-1.8.0.ebuild
new file mode 100644
index 000000000000..60d2cdba745a
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="
+ https://libnacl.readthedocs.io/
+ https://github.com/saltstack/libnacl/
+ https://pypi.org/project/libnacl/
+"
+# forked because upstream didn't push the tag for almost a year now
+SRC_URI="
+ https://github.com/mgorny/libnacl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
+
+RDEPEND="
+ dev-libs/libsodium
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -p 'test_*.py' tests/ ||
+ die "Tests failed with ${EPYTHON}"
+}