summaryrefslogtreecommitdiff
path: root/dev-python/liblarch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/liblarch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/liblarch')
-rw-r--r--dev-python/liblarch/Manifest3
-rw-r--r--dev-python/liblarch/liblarch-2.1.0.ebuild27
-rw-r--r--dev-python/liblarch/metadata.xml18
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/liblarch/Manifest b/dev-python/liblarch/Manifest
new file mode 100644
index 000000000000..09fed24c5177
--- /dev/null
+++ b/dev-python/liblarch/Manifest
@@ -0,0 +1,3 @@
+DIST liblarch-2.1.0.tar.gz 26829 BLAKE2B 14bf85bb91d800e5ca0d8eb4da6c2d9b3979b4560280776c276cad9cbd026331768729e5b4ca9b4646c6b199566cfb5a42b5148ef089e0ae5ec7e45d09090ba5 SHA512 fd6a6c48142e434f49fb49d9dee874b88f013775c280dd2dc929ed5fff4df7bd3743bf915b09dac4329f894cac24e466d78366a072136de389725bc5ed985ec1
+EBUILD liblarch-2.1.0.ebuild 626 BLAKE2B de6b3101ddc26980b7fd4ebad5f2b6ebcfa3787c141aa762d5f3d04eb4e3b7238eedc3a8db1a390ffd1513ced24cabf44d8aa4dc188b43e8188a9afbbe34adb5 SHA512 e137786e5f705db99a1de668ccb2bb99c215d3a348bd61e3d38597837a5642f57e44214016751da48fd88eae7bd863b2e8d4c9e52a4429b20b2f51ccdeb2d4cc
+MISC metadata.xml 879 BLAKE2B 12639bd111a24c36fdac162624fa2bdc354d0a7b1466a3b7862e1a445ab1ae236ba665c355546a11ddc2078d0ceccbcf9a79e8788cf34cec0702279adabb962a SHA512 04c71b1abb5c7e1b0af8a2505d5228996385df5babcc33cd51309110a08825a751c6ef9e26e41d48ae58a39c2c3e70df1b39aaa05559133162a64ea79abb166f
diff --git a/dev-python/liblarch/liblarch-2.1.0.ebuild b/dev-python/liblarch/liblarch-2.1.0.ebuild
new file mode 100644
index 000000000000..2bba1e2d90f7
--- /dev/null
+++ b/dev-python/liblarch/liblarch-2.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to handle directed acyclic graphs"
+HOMEPAGE="https://live.gnome.org/liblarch"
+SRC_URI="http://gtg.fritalk.com/publique/gtg.fritalk.com/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+# This is what should be run if tarball included testsuite
+#python_test() {
+# ${PYTHON} "${S}"/run-tests
+#}
diff --git a/dev-python/liblarch/metadata.xml b/dev-python/liblarch/metadata.xml
new file mode 100644
index 000000000000..2597e15fa79f
--- /dev/null
+++ b/dev-python/liblarch/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>eva@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>leio@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Liblarch is a python library built to easily handle data structure such are lists, trees and directed acyclic graphs (tree where nodes can have multiple parents). There's also a liblarch-gtk binding that will allow you to use your data structure in a Gtk.Treeview.
+
+ Liblarch supports multiple views of one data structure and complex filtering. That way, you have a clear separation between your data themselves (Model) and how they are displayed (View).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">liblarch/liblarch</remote-id>
+ </upstream>
+</pkgmetadata>