summaryrefslogtreecommitdiff
path: root/dev-python/libcloud/libcloud-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/libcloud/libcloud-3.3.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/libcloud/libcloud-3.3.0.ebuild')
-rw-r--r--dev-python/libcloud/libcloud-3.3.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/libcloud/libcloud-3.3.0.ebuild b/dev-python/libcloud/libcloud-3.3.0.ebuild
deleted file mode 100644
index 0c5711501b8b..000000000000
--- a/dev-python/libcloud/libcloud-3.3.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Unified Interface to the Cloud - python support libs"
-HOMEPAGE="https://libcloud.apache.org/"
-SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
-S="${WORKDIR}/apache-${P}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/cryptography-2.6.1[${PYTHON_USEDEP}]
- dev-python/lockfile[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- if use examples; then
- mkdir examples || die
- mv example_*.py examples || die
- fi
-
- # needed for tests
- cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
-
- # Needs network access
- sed -i -e "s/test_list_nodes_invalid_region(self):/_&/" \
- libcloud/test/compute/test_ovh.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}