summaryrefslogtreecommitdiff
path: root/dev-python/libcloud/libcloud-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/libcloud/libcloud-1.5.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/libcloud/libcloud-1.5.0.ebuild')
-rw-r--r--dev-python/libcloud/libcloud-1.5.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/libcloud/libcloud-1.5.0.ebuild b/dev-python/libcloud/libcloud-1.5.0.ebuild
deleted file mode 100644
index 414bc3b2bb65..000000000000
--- a/dev-python/libcloud/libcloud-1.5.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# py3 dropped due to failing tests once lockfile installed
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Unified Interface to the Cloud - python support libs"
-HOMEPAGE="https://libcloud.apache.org/"
-SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/lockfile[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' python{2_7,3_4} pypy)
- )"
-
-# Known test failures
-RESTRICT="test"
-
-S="${WORKDIR}/apache-${P}"
-
-python_prepare_all() {
- if use examples; then
- mkdir examples
- mv example_*.py examples || die
- fi
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
- distutils-r1_src_test
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}