summaryrefslogtreecommitdiff
path: root/dev-python/lhafile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-25 19:25:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-25 19:25:33 +0000
commit67dbd3ba144944fbf4b466be1b5fa0569b774e6f (patch)
tree721c7f9085992578da57f71ea0c5becb6827cdb4 /dev-python/lhafile
parentd4653056cc74d97f24bef0d56b4ebe11c53c8b76 (diff)
gentoo auto-resync : 25:02:2025 - 19:25:33
Diffstat (limited to 'dev-python/lhafile')
-rw-r--r--dev-python/lhafile/Manifest2
-rw-r--r--dev-python/lhafile/lhafile-0.3.1.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/lhafile/Manifest b/dev-python/lhafile/Manifest
index b96579884204..6084c69ea149 100644
--- a/dev-python/lhafile/Manifest
+++ b/dev-python/lhafile/Manifest
@@ -1,3 +1,5 @@
DIST python-lhafile-0.3.0.gh.tar.gz 267965 BLAKE2B 1331f21059f84f5e517339ac26546d73bc9dc125578840bf24483c274b651d8f0e2494b1b7e140bede07412b5c44e499269ea23dd1180bb955b1044b06d82ee8 SHA512 bb4db2767a702d30f2e713e5f7890d619de312d609761ade2ff8f4e99ffede8e35a72cd116abf3b8ea29b0885ebe2c993dc37f44722c8e5fe346be93dfdbbf81
+DIST python-lhafile-0.3.1.gh.tar.gz 267152 BLAKE2B e4d07b22aa036979e2db1ab3ffa54910e4fdad99201366f07a4fc9173e4f114cf6c46d910397324c72a9517c5a7f4bf4e9ce713f20eb68bc11cd79610a14e7b5 SHA512 73fcb03fe4436bbeab822e40fc4a9f02b67d2b99f2307e3e9ae894a768001ad662adf659fe1170ac0eb231b12e93b1c0429246396e16e0c1e149bd3cf7af8393
EBUILD lhafile-0.3.0-r1.ebuild 629 BLAKE2B 30bff91d4eb76597c27ee825a08966687eec9bfa3c3eaaaf0bb0304219b94041d9ae3ac50164a3b0cb378c304f2f7a6880a2bd7bf59ea7450bf74bcf81bb2b42 SHA512 02012ecdef8247bd159ed35a4634d78157baa4f9e934f54aa33ed529ac61405d321e5bfdb705e2dfa0e4855f41883a8286e0306e1362676d93ea80a81aa2e473
+EBUILD lhafile-0.3.1.ebuild 629 BLAKE2B 4c99b7b0892d5431c27cf6aa69b0b458736cc4f97a0354d9661f8e6ae93b52e1efd0ba777f13c0713d619dba975af7885f591ba02ff41576ac55af218580b63f SHA512 0d1cb04deb725596003316ee4a426735d3b3fd54299e9b7104e64a581dc0abe8f834ce15c781a690ff10755cb35c2b35ffe6a52388f90644c77923dd8dbc1ae0
MISC metadata.xml 385 BLAKE2B 80db4c058b52ca27106f3193c72d6878eea325a47425c65445d4e237739c297591bc1b70c188d98d5b717b5170cb69b01670fd2db00f62a5b8e84f1a627cf513 SHA512 a30340cd6218bb020e8529200c92eb245c43fd3c0f6d53f544f444c443b54d178a2c715a846a41a534799fb6cb52966eb970938297a1871676564085acf041bc
diff --git a/dev-python/lhafile/lhafile-0.3.1.ebuild b/dev-python/lhafile/lhafile-0.3.1.ebuild
new file mode 100644
index 000000000000..300adeeb2d44
--- /dev/null
+++ b/dev-python/lhafile/lhafile-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-lhafile-${PV}
+DESCRIPTION="LHA archive support for Python"
+HOMEPAGE="
+ https://github.com/FrodeSolheim/python-lhafile/
+ https://pypi.org/project/lhafile/
+"
+SRC_URI="
+ https://github.com/FrodeSolheim/python-lhafile/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+RESTRICT="test" # The tests don't work, they're probably outdated.