summaryrefslogtreecommitdiff
path: root/dev-python/ldap3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ldap3
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ldap3')
-rw-r--r--dev-python/ldap3/Manifest5
-rw-r--r--dev-python/ldap3/ldap3-2.2.3.ebuild31
-rw-r--r--dev-python/ldap3/ldap3-2.4.1.ebuild33
-rw-r--r--dev-python/ldap3/metadata.xml16
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/ldap3/Manifest b/dev-python/ldap3/Manifest
new file mode 100644
index 000000000000..7c6ffb28b38b
--- /dev/null
+++ b/dev-python/ldap3/Manifest
@@ -0,0 +1,5 @@
+DIST ldap3-2.2.3.tar.gz 331483 BLAKE2B a6479e6a02d0a0682b809cea2b63ff9ff3935f2d083b9dff3a02468d3a27cbc75dc69dff64f523c0b077f288b3e1e565433af13a607568617c309c3e894d7a62 SHA512 a954f6c582e88addf0bd6dc6fb24108d76d134b80c14a3dca0f9f667dbbfee484cb7b0444822f7e82a41af7dacf61ba111b6dcbf215b7f6df26a3784cfd2fc83
+DIST ldap3-2.4.1.tar.gz 345220 BLAKE2B bcf2ea46d483fd4fbfa7ba48e2a2e72061e82b56ac5bcad0e28aec0d52a723d5e5b2aad1f1c335977edeb260264a5603aa2a2bb726c08fd46a0215c46ad2f287 SHA512 716671c2d07c53d1953aab4668562a1b59a1e642b19d50f3cf05d44c74b6848a34b4197aa2c77f5b1d6b556ec0ca473b0495c24da74e2395aa20dffc8a0a360d
+EBUILD ldap3-2.2.3.ebuild 872 BLAKE2B a8f1b1bf36b4c4e4d0d34a7634a2ecbc191852331fb679c7184f2ff52d036ba7648afca859ddbf200345477d8a1acac3fca1de711513becca562337c8dd3e01e SHA512 5ba79edb0263a2a28d8309e95feb5bba61bd4628479a6a85ed085441ba7658743659aa206f42351c97a4b9ad8a1d82ddba100af80c32d1e769fc281386501e2e
+EBUILD ldap3-2.4.1.ebuild 875 BLAKE2B 1a2c0bc78e03e83e6bf873a6ec1b62557a38bbd2a4127d9afb9215b15423b821f7861a6775e17484e67f7888ea4ab8f460bb87e3094eca64e297e3b5830b9fe1 SHA512 72fba8ca614564cea85a86bcd475591fc13842271a5362ca84200393a60b78a8b69b2273b98f574bbc58b40fdae7af058184feb27bb26f0f4c5ba47ff734037d
+MISC metadata.xml 667 BLAKE2B 3dd9eac5fd53006653b3e1416ea1b7b4445daee2d041dce6672043effb4a4dc919503ab06b18b6e077981749f25b787657a3f8ab7d68572eefcda78af4c15faa SHA512 f92f6b96a6d9c32f959d278edd654495b0e8350ade72dde717b285667c0a6a9f472ca164b8c5f7e96b6f4aab1f48368a4a5836f75ff5e55941f8953b6b02e747
diff --git a/dev-python/ldap3/ldap3-2.2.3.ebuild b/dev-python/ldap3/ldap3-2.2.3.ebuild
new file mode 100644
index 000000000000..79692644bb5c
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.org/project/ldap3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+# The tests are a mess, and the test config is not included in the
+# PyPi tarball (see https://travis-ci.org/cannatag/ldap3 and
+# https://github.com/cannatag/ldap3/blob/master/test/config.py).
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ nosetests -v -s test || die
+}
diff --git a/dev-python/ldap3/ldap3-2.4.1.ebuild b/dev-python/ldap3/ldap3-2.4.1.ebuild
new file mode 100644
index 000000000000..0b8cb7a8fa84
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# The tests are a mess, and the test config is not included in the
+# PyPi tarball (see https://travis-ci.org/cannatag/ldap3 and
+# https://github.com/cannatag/ldap3/blob/master/test/config.py).
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pyasn1[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests -v -s test || die
+}
diff --git a/dev-python/ldap3/metadata.xml b/dev-python/ldap3/metadata.xml
new file mode 100644
index 000000000000..3e6256f8c0b6
--- /dev/null
+++ b/dev-python/ldap3/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ ldap3 is a strictly RFC 4511 conforming LDAP V3 pure Python client. The same codebase works with Python, Python 3, PyPy and PyPy3.
+ This project was formerly named python3-ldap. The name has been changed to avoid confusion with the python-ldap library.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">ldap3</remote-id>
+ <remote-id type="github">cannatag/ldap3</remote-id>
+ </upstream>
+</pkgmetadata>