summaryrefslogtreecommitdiff
path: root/dev-python/lark-parser/lark-parser-0.11.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-python/lark-parser/lark-parser-0.11.3.ebuild
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-python/lark-parser/lark-parser-0.11.3.ebuild')
-rw-r--r--dev-python/lark-parser/lark-parser-0.11.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/lark-parser/lark-parser-0.11.3.ebuild b/dev-python/lark-parser/lark-parser-0.11.3.ebuild
new file mode 100644
index 000000000000..9e3a41734141
--- /dev/null
+++ b/dev-python/lark-parser/lark-parser-0.11.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to propose a modern general-purpose parsing library for Python"
+HOMEPAGE="https://github.com/lark-parser/lark"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/js2py[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" -m tests -v || die "Tests fail with ${EPYTHON}"
+}