summaryrefslogtreecommitdiff
path: root/dev-python/larch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/larch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/larch')
-rw-r--r--dev-python/larch/Manifest5
-rw-r--r--dev-python/larch/larch-1.20130808.ebuild34
-rw-r--r--dev-python/larch/larch-1.20131130.ebuild34
-rw-r--r--dev-python/larch/metadata.xml8
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/larch/Manifest b/dev-python/larch/Manifest
new file mode 100644
index 000000000000..4bfc576e8de2
--- /dev/null
+++ b/dev-python/larch/Manifest
@@ -0,0 +1,5 @@
+DIST python-larch_1.20130808.orig.tar.gz 88271 BLAKE2B 0a797c05ce5e177af608720a6711cd52d1d82929002ff98e51291fe0f918f571e6bae2d616e49835ceb0efe9436cd24d1c9b6fabcc316d73c06cf0ba41518a86 SHA512 84bab884e3ff8e27cc43e2520eb10fb7a38d99eddb06b9163e174329d69552e678ef81d606fa041f894794f0ba3bdf59ace3081f71596869e1167a0e23d56c85
+DIST python-larch_1.20131130.orig.tar.gz 86509 BLAKE2B f964bf4af316e010cc40513e3a767ee7d0f058ec78bfa417931ae0087e0b8d0e0c577bd99b5edfedce560fc3d21747a81e75dc1ed3527f9b054d3e8e55df7f38 SHA512 e661fa29043a5254eb3615f0eb54f6afbaf59020607bb72f621083e9f6acfbe92b1c978ce2be73336d8984a4a64ce6d0153556f0af0ca63ad53aff40f785d052
+EBUILD larch-1.20130808.ebuild 670 BLAKE2B 616e307de7755446f6c5050ca43109910cf1128441e09dc94d765d39f2c959cd1ed3e932971a7a996a056a02f6b0663c99e1aa7d862efaebac8153c922015362 SHA512 3fe27d8f94fe95e777a10ef2ff23b58865b5ce367b471b7a26b586af605a853120c81c2a368abe8ae5c9c226923d90ddde204d55d780123f2bb67b9e10f8bd40
+EBUILD larch-1.20131130.ebuild 670 BLAKE2B 616e307de7755446f6c5050ca43109910cf1128441e09dc94d765d39f2c959cd1ed3e932971a7a996a056a02f6b0663c99e1aa7d862efaebac8153c922015362 SHA512 3fe27d8f94fe95e777a10ef2ff23b58865b5ce367b471b7a26b586af605a853120c81c2a368abe8ae5c9c226923d90ddde204d55d780123f2bb67b9e10f8bd40
+MISC metadata.xml 250 BLAKE2B fef48a48388f26a915c53bca9aa9cab62fb73ec006736542afb4cbbe0c7b81d23afe2884f52433c7d390fc38ac32f957a6f6efe285ee1cafaed76407a964cf9b SHA512 924271cfb32ceafc4134e19b53fbeed96f2e9056addc3c2cbdec28890254abf5f0714979a3ab698ca046e41ef5c2cca2932350830bd8bd3a8e214d99123c12de
diff --git a/dev-python/larch/larch-1.20130808.ebuild b/dev-python/larch/larch-1.20130808.ebuild
new file mode 100644
index 000000000000..7154cb4765f6
--- /dev/null
+++ b/dev-python/larch/larch-1.20130808.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy-on-write B-tree data structure"
+HOMEPAGE="http://liw.fi/larch/"
+SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
+#RESTRICT="test"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/CoverageTestRunner dev-util/cmdtest )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/cliapp
+ dev-python/tracing
+ dev-python/ttystatus"
+
+src_test() {
+ addwrite /proc/self/comm
+ distutils-r1_src_test
+}
+
+python_test() {
+ emake check
+}
diff --git a/dev-python/larch/larch-1.20131130.ebuild b/dev-python/larch/larch-1.20131130.ebuild
new file mode 100644
index 000000000000..7154cb4765f6
--- /dev/null
+++ b/dev-python/larch/larch-1.20131130.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy-on-write B-tree data structure"
+HOMEPAGE="http://liw.fi/larch/"
+SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
+#RESTRICT="test"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/CoverageTestRunner dev-util/cmdtest )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/cliapp
+ dev-python/tracing
+ dev-python/ttystatus"
+
+src_test() {
+ addwrite /proc/self/comm
+ distutils-r1_src_test
+}
+
+python_test() {
+ emake check
+}
diff --git a/dev-python/larch/metadata.xml b/dev-python/larch/metadata.xml
new file mode 100644
index 000000000000..ea6b59e79026
--- /dev/null
+++ b/dev-python/larch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+</pkgmetadata>