summaryrefslogtreecommitdiff
path: root/dev-python/larch/larch-1.20131130.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/larch/larch-1.20131130.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/larch/larch-1.20131130.ebuild')
-rw-r--r--dev-python/larch/larch-1.20131130.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/larch/larch-1.20131130.ebuild b/dev-python/larch/larch-1.20131130.ebuild
new file mode 100644
index 000000000000..7154cb4765f6
--- /dev/null
+++ b/dev-python/larch/larch-1.20131130.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy-on-write B-tree data structure"
+HOMEPAGE="http://liw.fi/larch/"
+SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
+#RESTRICT="test"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/CoverageTestRunner dev-util/cmdtest )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/cliapp
+ dev-python/tracing
+ dev-python/ttystatus"
+
+src_test() {
+ addwrite /proc/self/comm
+ distutils-r1_src_test
+}
+
+python_test() {
+ emake check
+}