summaryrefslogtreecommitdiff
path: root/dev-python/kombu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/kombu
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/Manifest2
-rw-r--r--dev-python/kombu/kombu-4.6.8.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/kombu/Manifest b/dev-python/kombu/Manifest
index 807533bc316b..aa365e3d2cbb 100644
--- a/dev-python/kombu/Manifest
+++ b/dev-python/kombu/Manifest
@@ -1,3 +1,5 @@
DIST kombu-4.6.3.tar.gz 427754 BLAKE2B 0db078eb8d6afd18a5e9b48c970791d2c55c46f5f705e8e0737c8685c2415e1ca974594377a54764f744cc73ff607668ece3c0999b1a7dad6a259567ac1fd319 SHA512 35113c4f19fe6bf94c374477c89a629f565975a23c16a3cedefa8e0c2a800cabbaa8917d48f732cf28e89cd5430fe8408a3514e055b1858c216b6ea31b4c014a
+DIST kombu-4.6.8.tar.gz 406196 BLAKE2B 43ddb45e7e6a5bc1aff55867a816ebf7a1afed68bd41d9d74b6179a45d951ac4a4f0f687bbaebd23cf81b67fe2b81d47498b3e25eead0822e16d9acbb436338a SHA512 65b4ebb283ae380388de5d9f8fdc1ec0f41a9910744906b23eb150bc62ecb55ae6d65bb96ad31d8a033f26c2a8dc386939fced393866b6467e77a9760dfa17cc
EBUILD kombu-4.6.3.ebuild 2311 BLAKE2B 3cc134c1c83e228ed750244514d4d0f9e7556efa77361b1660624d8552374fe6af83174ea60e4c6466661f18952aa7a086652dfd0e8e2e99b7bedc95e3ecb0e6 SHA512 74c33f886c0803e35e334dc582c1d7ed3001a5149caf3d3885c3c599733f760839b1cebc36e71ff2c6e227f690eaaa450a08b256b5cf4bab36df54b196348551
+EBUILD kombu-4.6.8.ebuild 2370 BLAKE2B c2b6e27b61d9f0c2b66b8621b05a39510e15e8a4dea59519cd24c1e884f85279ef0e739a4835387e9688cbdc31d03e7e9e32dff9dba699c878e8349152039d04 SHA512 5a508a2eb2db0f31654ce0f153aaed239e66429c5501d44d9e04f3631de0925b74827021d2a9652c37d19cc50edd82d1945adff68c1b47716d863c8e8ad6d722
MISC metadata.xml 675 BLAKE2B 6bab5465ca22ad8ab27ff08418abb6c6616972605b2b9bec7ec559f887962c80df01e6c9aa8eed5b1ffcbc392a8476f86ea477fa3c4084ba37e1ba350786f8d5 SHA512 37288783570daecc3bd70a8f5e9b96e652cd2271f1a36f9ecd644b6fb98f4dadbb2f2cbe36457c46d4b99d67fc5cfa6fea78f37bfd96b3b639cd26de4e948541
diff --git a/dev-python/kombu/kombu-4.6.8.ebuild b/dev-python/kombu/kombu-4.6.8.ebuild
new file mode 100644
index 000000000000..838b1c73c56d
--- /dev/null
+++ b/dev-python/kombu/kombu-4.6.8.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="https://pypi.org/project/kombu/ https://github.com/celery/kombu"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc examples mongodb msgpack redis sqs test yaml"
+RESTRICT="!test? ( test )"
+
+# zookeeper backend support possible via dev-python/kazoo
+RDEPEND="
+ >=dev-python/importlib_metadata-0.18[${PYTHON_USEDEP}]
+ >=dev-python/py-amqp-2.5.2[${PYTHON_USEDEP}]
+ <dev-python/py-amqp-2.6[${PYTHON_USEDEP}]
+ >=dev-python/pyro-4.76:4[${PYTHON_USEDEP}]
+ sqs? ( >=dev-python/boto3-1.4.4[${PYTHON_USEDEP}] )
+ msgpack? ( >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}] )
+ mongodb? ( >=dev-python/pymongo-3.3.0[${PYTHON_USEDEP}] )
+ redis? ( >=dev-python/redis-py-3.3.11[${PYTHON_USEDEP}] )
+ yaml? ( >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}] )"
+# Fix to https://github.com/celery/kombu/issues/474 obliges dev-python/pymongo to >=-3.0.2
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-20.6.7[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/case-1.5.2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_celery-1.1[${PYTHON_USEDEP}] )"
+
+# kazoo is optional for tests.
+# Refrain for now, no established demand for it from users
+
+# Req'd for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+)
+
+python_prepare_all() {
+ # AttributeError: test_Etcd instance has no attribute 'patch'
+ rm t/unit/transport/test_etcd.py || die
+ # allow use of new (renamed) msgpack
+ sed -i '/msgpack/d' requirements/extras/msgpack.txt || die
+ # pytest-sugar is not packaged
+ sed -i '/pytest-sugar/d' requirements/test.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # Doc build misses and skips only content re librabbitmq which is not in portage
+ if use doc; then
+ emake -C docs html
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}