summaryrefslogtreecommitdiff
path: root/dev-python/keyring/keyring-23.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 02:15:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 02:15:09 +0100
commit3fd9d065ab109700e92fc1cea2a6519a39a5b007 (patch)
tree2666118c9404e846180636fbd2de92e3bd7870fd /dev-python/keyring/keyring-23.8.2.ebuild
parent11c791ab62dc711840a52676eef212362840fc17 (diff)
gentoo auto-resync : 09:08:2022 - 02:15:09
Diffstat (limited to 'dev-python/keyring/keyring-23.8.2.ebuild')
-rw-r--r--dev-python/keyring/keyring-23.8.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/keyring/keyring-23.8.2.ebuild b/dev-python/keyring/keyring-23.8.2.ebuild
new file mode 100644
index 000000000000..a90ebe22521a
--- /dev/null
+++ b/dev-python/keyring/keyring-23.8.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="
+ https://github.com/jaraco/keyring/
+ https://pypi.org/project/keyring/
+"
+SRC_URI="
+ https://github.com/jaraco/keyring/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/secretstorage-3.2[${PYTHON_USEDEP}]
+ >=dev-python/jeepney-0.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # this test fails if importlib-metadata returns more than one
+ # entry, i.e. when keyring is installed already
+ tests/test_packaging.py::test_entry_point
+)
+
+EPYTEST_IGNORE=(
+ # apparently does not unlock the keyring properly
+ tests/backends/test_libsecret.py
+ # hangs
+ tests/backends/test_kwallet.py
+)