summaryrefslogtreecommitdiff
path: root/dev-python/kafka-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 14:24:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 14:24:26 +0000
commit171d09fa1f429aa43835c618a2c21753ad5209a4 (patch)
tree7a9f3e0ed5e5a7dbabf98c971e8202b7ce50035b /dev-python/kafka-python
parent1826a30af36ae674cb71400eacaf0a0762df510f (diff)
gentoo auto-resync : 21:02:2023 - 14:24:25
Diffstat (limited to 'dev-python/kafka-python')
-rw-r--r--dev-python/kafka-python/Manifest4
-rw-r--r--dev-python/kafka-python/kafka-python-2.0.2-r1.ebuild51
-rw-r--r--dev-python/kafka-python/kafka-python-2.0.2.ebuild4
3 files changed, 56 insertions, 3 deletions
diff --git a/dev-python/kafka-python/Manifest b/dev-python/kafka-python/Manifest
index ebad3c470af2..7a0b5b25598d 100644
--- a/dev-python/kafka-python/Manifest
+++ b/dev-python/kafka-python/Manifest
@@ -1,3 +1,5 @@
+DIST kafka-python-2.0.2.gh.tar.gz 327238 BLAKE2B 9d8bdee1cedcc3c7c0bee9d900bb815552b29f50ec45b7db9d1052a26eb772c84d92648ccc0d498189fc44314f5c8c30529fa61cb983481f2e2480e009630f91 SHA512 e193a8fe5852d2134e854749115feba46a0b8ff748336989a27bf56acba1124dbb8a5d841670a67ee26eef030a686d931d03d329f978b2eef7904183e83d2594
DIST kafka-python-2.0.2.tar.gz 327238 BLAKE2B 9d8bdee1cedcc3c7c0bee9d900bb815552b29f50ec45b7db9d1052a26eb772c84d92648ccc0d498189fc44314f5c8c30529fa61cb983481f2e2480e009630f91 SHA512 e193a8fe5852d2134e854749115feba46a0b8ff748336989a27bf56acba1124dbb8a5d841670a67ee26eef030a686d931d03d329f978b2eef7904183e83d2594
-EBUILD kafka-python-2.0.2.ebuild 1267 BLAKE2B 79cd03b7739bb93aa63d4e34e2668a954b3709cf1981f8aa0efbae793aed162ce551afaecde72d23d7ee083bd2d47f4ce49be849227a135186f0b054c5112860 SHA512 0ae00f707aaf3a70315e2ea40916ad25e38dcb240066e31a0dad0571a03907dff8502a768645b921dbeeb81a13ff1dc018e5060dec8263926cf675bc6ce5a5cf
+EBUILD kafka-python-2.0.2-r1.ebuild 1243 BLAKE2B ce1b498a3902df56c04e7fa733303445f225c6ae916bba521bb18e6d1e66fea2d98ea6f6c37c7ec7345c7b35d6bdf4a1e7e39acab82865639e850c66a5362f3f SHA512 bbcc915fc78d9b6f1e2c6a1da06e0a19e05c76d8796b37eeab4c4e3c5a2c04a4b41fa7def60ff95ea222f3213b82c7668f9198e5f0d02b2c4139668205314462
+EBUILD kafka-python-2.0.2.ebuild 1253 BLAKE2B 9aea38ba8e1d8da0c9745e262b0e29cbbebb3a6d778d58d63ddf3771b2b4f2267c5e81430dcda46baf440e17e0afce33f14ee2107348b13e4a40f8cf74ec0f66 SHA512 fd0dc5b0462dee96f2f33bc069ca51e67b085dc3af4488b27cba23edfcfd07d3c3b37d9b0198f5e29d2d507ecfd4c833acf22a722350a80a6bcd97056bf77c82
MISC metadata.xml 307 BLAKE2B d5a0188eb0aaf189135a021a211b30e2b641f31c83260999f8e0cc4cd12d78a9db90c5be3e5f958dd2f2ffef3177c1833c8e7d2c1b7624c3ccb0d2d5c7ddb868 SHA512 7452ad3874e6d102ebfe6ffa1a1c0ea37d477c100cfc434f9bc7259d04e08789bd2a926dca92f8e819de337028751b4738f24b9f8d2b9bcb59ef85053177b78a
diff --git a/dev-python/kafka-python/kafka-python-2.0.2-r1.ebuild b/dev-python/kafka-python/kafka-python-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..911f0ecfa1e6
--- /dev/null
+++ b/dev-python/kafka-python/kafka-python-2.0.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Kafka protocol support in Python"
+HOMEPAGE="
+ https://github.com/dpkp/kafka-python/
+ https://pypi.org/project/kafka-python/
+"
+SRC_URI="
+ https://github.com/dpkp/kafka-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/xxhash[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lz4[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ dev-python/python-snappy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Needs the unpackaged crc32c module
+ "test/record/test_util.py::test_crc32c[None]"
+ # Needs kafka server running
+ test/test_consumer_integration.py::test_kafka_consumer_offsets_for_time_old
+)
+
+pkg_postinst() {
+ optfeature "LZ4 compression/decompression support" dev-python/lz4
+ optfeature "Snappy compression support" dev-python/python-snappy
+ optfeature "ZSTD compression/decompression support" dev-python/zstandard
+}
diff --git a/dev-python/kafka-python/kafka-python-2.0.2.ebuild b/dev-python/kafka-python/kafka-python-2.0.2.ebuild
index b9bc7a22ab37..e66e23a38729 100644
--- a/dev-python/kafka-python/kafka-python-2.0.2.ebuild
+++ b/dev-python/kafka-python/kafka-python-2.0.2.ebuild
@@ -21,7 +21,7 @@ BDEPEND="
dev-python/lz4[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/python-zstandard[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
dev-python/python-snappy[${PYTHON_USEDEP}]
)"
@@ -40,5 +40,5 @@ python_test() {
pkg_postinst() {
optfeature "LZ4 compression/decompression support" dev-python/lz4
optfeature "Snappy compression support" dev-python/python-snappy
- optfeature "ZSTD compression/decompression support" dev-python/python-zstandard
+ optfeature "ZSTD compression/decompression support" dev-python/zstandard
}