summaryrefslogtreecommitdiff
path: root/dev-python/k5test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
commit9a8514e070a40648dbc8e28ad6457d925542b79a (patch)
tree5cc8ed0b0c8964ad196b7b3e502def202a997b32 /dev-python/k5test
parent2ecd7994be1409f2a65bfca700904d2a78fd7bbe (diff)
gentoo auto-resync : 26:10:2022 - 09:55:31
Diffstat (limited to 'dev-python/k5test')
-rw-r--r--dev-python/k5test/Manifest3
-rw-r--r--dev-python/k5test/files/k5test-0.10.1-which.patch41
-rw-r--r--dev-python/k5test/k5test-0.10.1-r2.ebuild (renamed from dev-python/k5test/k5test-0.10.1-r1.ebuild)10
3 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/k5test/Manifest b/dev-python/k5test/Manifest
index 741d9de34986..aa7c5dbe65a7 100644
--- a/dev-python/k5test/Manifest
+++ b/dev-python/k5test/Manifest
@@ -1,3 +1,4 @@
+AUX k5test-0.10.1-which.patch 1399 BLAKE2B 0ddd4f99103c94c4e73eb3be54c1844206b366e99bcc1a026ee6981fb1a02f09e98061ee79a03dff91f8fba16945141cb64025b1416f4ded03c1d672768d4b88 SHA512 fd699ffe140a90a961a18b1df30eec08b7fb4d4ade24a23d5d6586bd76dbc15e4c2b5a9b342346d81eab0d7d3bcbae9a62489423de641c26414cc964c9586009
DIST k5test-0.10.1.tar.gz 13664 BLAKE2B 4be24a8c9b154f5ec7b83b6743d0f756cb813bdfe4496c6f8ed873a2fc5a725c17b34f7b243d106d7a985aa53351f9bdc354fabba6a8c5fa3d25927513441cb4 SHA512 eaf451f0a932fdb8758f23e17ec52b2c1617074f186dddfba1d9c6844291fb2f4b003e05f4a0e02ce1bae37ee4251ea8295d2ebc8d9002c83d3179000fa4785e
-EBUILD k5test-0.10.1-r1.ebuild 479 BLAKE2B 01ae8e651203cf165a4dc7f7a163ce5036a00aaf0d2638533feb7b9353d8c0ff7ca10c86770f2315d21d56a7d8cf41a8ed5ed9b5bbcd6df093a2aeac8d15317c SHA512 de3422fb304b01735cc2d26bd1d6fa44e29e20f1b6475809881abaa17fc6aa56697caf47377efdfe2ef7d2dcba0fbe75c85e93a146e3296414fe66a6811de0e4
+EBUILD k5test-0.10.1-r2.ebuild 530 BLAKE2B a4c87827876715a4135958971a8c5dd6c572cfaa9dea1a2e38023602d5840a5977ff7311f37300f367651d486d507331383f7bb92c2b214e1b31f8cac500a81d SHA512 fcc787ef30afae89d07e4fe4776b36bb641ce4e2e3e88decd48db4890221862021f4038862f71d10c04e96f6ff150e9f5c778a439ab178563567f37524c0bb62
MISC metadata.xml 393 BLAKE2B dc1fec37db82ae2baa97fe324533b9105879142442ac6072b20721dc5233981d726fa56dbefaa0d51b85917ba64110395c2f7c57a9d8e88cb8ecb5bd9d116996 SHA512 b8dd2d38e1d2d95d9fac8a77be33973457a64afc771f3122f161db721b2b1ed71a9e569e498bd85494e498dba340e9a7d3137ea1c239d9ba8d8c19332ebfb1be
diff --git a/dev-python/k5test/files/k5test-0.10.1-which.patch b/dev-python/k5test/files/k5test-0.10.1-which.patch
new file mode 100644
index 000000000000..c5a72b5dc091
--- /dev/null
+++ b/dev-python/k5test/files/k5test-0.10.1-which.patch
@@ -0,0 +1,41 @@
+From cff2138124cb7461fe2b1a270d0c0132e6f66f6b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 26 Oct 2022 05:31:22 +0200
+Subject: [PATCH] Use built-in shutil.which() instead of which(1) tool
+
+Use the built-in shutil.which() function that is available since Python
+3.3 instead of the external which(1) program. The latter is not part
+of POSIX and may be missing entirely (Gentoo is activately working
+towards removing it)>
+---
+ k5test/realm.py | 11 ++++-------
+ 1 file changed, 4 insertions(+), 7 deletions(-)
+
+diff --git a/k5test/realm.py b/k5test/realm.py
+index 8b24141..2260258 100644
+--- a/k5test/realm.py
++++ b/k5test/realm.py
+@@ -68,16 +68,13 @@ def _cfg_merge(cfg1, cfg2):
+
+
+ def _discover_path(name, default, paths):
+- stderr_out = subprocess.DEVNULL
+- try:
+- path = subprocess.check_output(["which", name], stderr=stderr_out).strip()
+- path = path.decode(sys.getfilesystemencoding() or sys.getdefaultencoding())
++ path = shutil.which(name)
++ if path is not None:
+ _LOG.debug(f"Using discovered path for {name} ({path})")
+- return path
+- except subprocess.CalledProcessError as e:
++ else:
+ path = paths.get(name, default)
+ _LOG.debug(f"Using default path for {name} ({path}): {e}")
+- return path
++ return path
+
+
+ class K5Realm(metaclass=abc.ABCMeta):
+--
+2.38.1
+
diff --git a/dev-python/k5test/k5test-0.10.1-r1.ebuild b/dev-python/k5test/k5test-0.10.1-r2.ebuild
index cd681b4fed98..aa48a24cd102 100644
--- a/dev-python/k5test/k5test-0.10.1-r1.ebuild
+++ b/dev-python/k5test/k5test-0.10.1-r2.ebuild
@@ -5,12 +5,20 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="Library for testing Python applications in Kerberos 5 environments"
-HOMEPAGE="https://pypi.org/project/k5test/ https://github.com/pythongssapi/k5test"
+HOMEPAGE="
+ https://github.com/pythongssapi/k5test/
+ https://pypi.org/project/k5test/
+"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-which.patch
+)