summaryrefslogtreecommitdiff
path: root/dev-python/jwcrypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-15 23:13:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-15 23:13:45 +0100
commite87ef1b6ce856ae8859bdfce8028fb992f3e3763 (patch)
treed51e0c41adf3586e9a393881cee3ec0a9ed48977 /dev-python/jwcrypto
parent0c80ffd3caee224555f8b394b6b2c05b2752f440 (diff)
gentoo auto-resync : 15:09:2022 - 23:13:44
Diffstat (limited to 'dev-python/jwcrypto')
-rw-r--r--dev-python/jwcrypto/Manifest2
-rw-r--r--dev-python/jwcrypto/jwcrypto-1.4.2.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index 987cc7c7a09d..3d555c6f20f5 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1,3 +1,5 @@
DIST jwcrypto-1.3.1.gh.tar.gz 91903 BLAKE2B 49fb3cb9548c85d406d47074a410f6bc89cbc32f16a0244b4ac5e3fa219bc66fc1e4ed32056f5c9885608b5225c2ed3423555813938465924e60dabb8f39749b SHA512 bc43a1acdb12a4e25251a3c5f9c85286c5a4234bd098efe69b7e3bd3da9ec72e80d7239cc20b1f971e17218cce9a7febe6a92efca33da2f2e1479fe64150bb71
+DIST jwcrypto-1.4.2.gh.tar.gz 94465 BLAKE2B 23b3a18694793cdbdd1875bd9b107ecab8248ac2c6cbf1bf142144633f7dc6efea91b693b808a4a6153b78c1117dbb2fe1f831f7f2558d2476e146961a501c17 SHA512 9967e626bc4a13a12ef09bbf3dada589c2c5374f4addff743c3ca9762c66659f59ca2e0f495cda6bc5821b6ed62aae95d478bf14de0acd6b2696bf0e1a9e7a49
EBUILD jwcrypto-1.3.1.ebuild 842 BLAKE2B d81c732703a83443f1bab3668256170a4c3a44691c891d6dcf06c68c1fa7283268bba5a5005fca7db7ca9af3785bc5ad056282fed4c3e6fd23a135b3f3a8d126 SHA512 9f8f2f49bbb7704f477a4a7eb9bed40e63261348c0d972e91d7b991ed5da168955c10787ea85865032bb033f81d983046fc15da8060dde557dab52b8a201b42e
+EBUILD jwcrypto-1.4.2.ebuild 847 BLAKE2B a1aa7608405aa4fbcf1763ebfb46c9f904431dda31978a6ae474919012b94f6a0fab40dd5d5642c4bded38d4b075b31c4090d6803abf3fed447f83dade868925 SHA512 55947c42faea78a660ff9fb17a8f900a169a2a1884cd7feaf4f0da44bc1d8fa096293e7d5c7f366913f093b2e755b29e35c313023456599a179504d6262aff9d
MISC metadata.xml 369 BLAKE2B c7868e0b20a2875964290642cddb457b71628e361f0e032875ac45f4405abeb76c8c53bcfe623c9a2e49ea6e184505503b4e43f34c456528ff3250aea5110b10 SHA512 a1fec6ac31bbb096e508b0ebd644aa8a96418e6972d852512d4b7702b67f241f858610235dbd68430c588d8b837c7a0866f333c8aab182e7cd01e10325031d34
diff --git a/dev-python/jwcrypto/jwcrypto-1.4.2.ebuild b/dev-python/jwcrypto/jwcrypto-1.4.2.ebuild
new file mode 100644
index 000000000000..e6056edc5f0d
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-1.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+HOMEPAGE="
+ https://github.com/latchset/jwcrypto/
+ https://pypi.org/project/jwcrypto/
+"
+SRC_URI="
+ https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -e "/data_files/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}