summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-19 12:29:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-19 12:29:09 +0100
commitc59df12b8749ab7bbd5a0692072652d4fbb0d2cf (patch)
treeb0c755a8dc7206de06d287c623e493927679f700 /dev-python/jupyterlab
parentf85858c81a721c7fc89c1ab8df19e3a213dc27cd (diff)
gentoo auto-resync : 19:07:2024 - 12:29:09
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.2.4.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index f29d17cc9607..c85ddfc12b80 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab-4.2.3.tar.gz 21505072 BLAKE2B 8cc9aaed2fb848ecad6fb408968d66583ed69752cd8b5f62e19949b7aa5180d66950802649c137feddeab9e26f5ecb0394b7fdba751a4d784d00625d9b750fd3 SHA512 4ed3dd40ee43a05c8393531b87f568f3ffab43f20d1e8c8ad96c90bed4f67d6c83ab0a2664098cd5e39580427e03f4170eb4d91e9b8cc924b70f977db3cdc7de
+DIST jupyterlab-4.2.4.tar.gz 21506914 BLAKE2B b130f91807c96d57d01127a37dcac1589422ef36023e9b02a32ade9c2ceedf128fce49d1a11dfbb5836dd5f40a0828e32f625cb3d99eb0098785b5be6b56eeba SHA512 2327c7d7b63185c9e1a90acfcac4b31224835601ed8e0bb545077e0c68f6cbb612af884fef288b7e28245b83a035542590cbd721b0f9e44af27bb4aa8a00acab
EBUILD jupyterlab-4.2.3.ebuild 2760 BLAKE2B e5f0a51d2c22bd4feece54cefe493e5d2dee0de04f768e18c056f35009abdfa01b0f1d117f4d2a5620a8e64e7238342f8bbb59f56e42429cef8d12dd6e8dbfef SHA512 b91b9d7d4fc1e19a7a2b28f9cc34f1de3a533771ef51bf396fc9134d6e6002282f75a1e6d0343558becc8867a33c797e3f92d1317de34fa5008e623d17ba54b8
+EBUILD jupyterlab-4.2.4.ebuild 2765 BLAKE2B 18508727647b6c8a027dfcbe6f4930e17d466a5e300093a58a05e571feb4b2b5b35a0ee1e42bdd5793ff7e81a1dfc74436493dbe8417279092c4a7fadce009bb SHA512 1ad2ee34bab187e5f6ae22b0032456a490ad7f22def66af2a2c50f890688921917a0e712a5063112203d35fcd06ea38f71b8b339045f7d4a5131ed6d1b526520
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-4.2.4.ebuild b/dev-python/jupyterlab/jupyterlab-4.2.4.ebuild
new file mode 100644
index 000000000000..70f94aa414ed
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-4.2.4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi xdg
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/async-lru[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.5.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.27.1[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-40.0.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/tornado-6.2.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}