summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
commitb46782805d0eed36ce9685f7e9abf25671f24d7d (patch)
tree4b7992f7355b710c35a7c4bfff9b57eb64e4c8b5 /dev-python/jupyterlab
parentd4d7098dcb2f9dd257109bbcb55fd40beda1b78d (diff)
gentoo auto-resync : 21:12:2022 - 01:52:55
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.5.2.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index 000abd007264..b476be6872a5 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab-3.5.0.tar.gz 17110889 BLAKE2B 89b20734dea44419af023b88c85b243fa3f8ac0c7272600729da8690eb53cd4286d9c9bb90e95e291644de3675a9daae63898d6621cc4c21b4fc8e0d965242b4 SHA512 43b893127b5b4f1ccd472dfe9152d4ac8f89192411d1fa6045e3ecfb5f8f16819d1cf4b6fd70d9656d25d10cafff55055da98d36d2c8537d5b07e29e2d157799
+DIST jupyterlab-3.5.2.tar.gz 17111761 BLAKE2B 77c63d8842f9e58a10ed3fae3ecd9cd6b10045d3aec1e90cbc83fe40bc7d4b5cbac4eabbaac2a36c77815cd27f332a35ffdf8ea5e7fd07e95893bd5bad5c68a4 SHA512 b6a5b314fc23e4a9164085827123c19570d112519c6651453006cc18f89c1eaac74871f6e8faf9ced4c32eada72912f72b2ab3cb2ff101ef6b6e3e70601494aa
EBUILD jupyterlab-3.5.0.ebuild 2533 BLAKE2B eecd6e04c843d0a1bbb4636297deaa9ece4c31250294b9db0b4796276e730539d536ad1942b49f7df2807fbb2a722603fa8f3f5e116d40b14978d30c4c2867be SHA512 0c8024f088bbd0763125d9bc4557d85501a2c873dcccb657cc2df1a5d4ea2a6b86d8cead6a4072d4751f602b21d3541494a4bd3f5b01598acf54e058491ab16e
+EBUILD jupyterlab-3.5.2.ebuild 2533 BLAKE2B 5b26137720ec6ae95dff604ff4cabd78879cf0783d1c7bdc61dca5d660f7400d5c938c3284041884ab4261e1a5bfeb1b5cdf82c1b76009cc6666e9de00f22823 SHA512 c7c48a2ceb07ae651c7158374e78c279bf5939a7f813426481778c73438c29e3e7887a56225faa01321d4c2ff74cfbcc02b7e6051f68116a58b368007d269e99
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-3.5.2.ebuild b/dev-python/jupyterlab/jupyterlab-3.5.2.ebuild
new file mode 100644
index 000000000000..6433f936ebdd
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-3.5.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=jupyter
+inherit distutils-r1
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/jupyter_packaging[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab_server-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.16[${PYTHON_USEDEP}]
+ >=dev-python/nbclassic-0.2[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="test? (
+ dev-python/check-manifest[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_server[${PYTHON_USEDEP}]
+ dev-python/openapi-core[${PYTHON_USEDEP}]
+ dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+)"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme dev-python/myst_parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}