summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-29 15:53:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-29 15:53:38 +0100
commit822a054dd1bab7f8080ccd486398034b4ff0b97d (patch)
treec64bfd54aca68af69ccf06b1a9d20365383e3ccc /dev-python/jupyterlab
parentf7436a5ce1c11f1c33cd09dd757f768cd07b19fd (diff)
gentoo auto-resync : 29:03:2023 - 15:53:38
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.6.2.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index ad0f3e5bd7bd..a8df01b37492 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,5 +1,7 @@
DIST jupyterlab-3.5.3.tar.gz 17114007 BLAKE2B 70d32721a2579331dd4e3481f7241f5e2c5aad6dac851f213de0ac1fc3b76667bea496bca5ea13ee562e9678d51ac45df91c5901d8d3b7dc839977d3d842e67d SHA512 fdacd34ab629da2b5c2eb23f11ba4d44d5b27872e1736850319bcabbe635d31cfa2891c1c5991b152a5c1d94221e3766a20fc91033f556d8e508374bc46d5fe2
DIST jupyterlab-3.6.1.tar.gz 16845937 BLAKE2B 41c50a9ddefc0ec97c70843e15107d3e3cebfadea2ec148e4536407b0f1b202c2aeace794b02c7cb666c316434da614c1bfebab5e5fc7e654f62677bac6e1eb3 SHA512 9dc63162955c13721c97d620a60116cd75bf10eca9c8eab08ae35749bf2dfec84c55759a361ca1abab34c44d63eded95748cfea589aff98907045b483d778413
+DIST jupyterlab-3.6.2.tar.gz 16846937 BLAKE2B 1b443ace53a68903728aa781a0a0aa95a13193b63ce3101144945e41245dd7c00554abc6c75a48feafc677d83580705393cde1a4bffab0e09d2d5bf0d67e72e0 SHA512 8ca7956f6c78413a7aecb55cd60b3dfa8491afbe3b02d9ae5b038ba4dcc762daf78768349cb586775483e8dee39d5a062650d0fd156e12a85383543f836cfb38
EBUILD jupyterlab-3.5.3.ebuild 2574 BLAKE2B eb478fdb0b5180dbb7efe3572bc2287fbb1b68ee2bf22380be4b7de88086f56aeeea7a9f8d5a2d62d52c45a7259bf495bdd69ef9a5184f65b05995d52838c772 SHA512 563417179f88b2bd8a27a715ed0da7dc3b8c5bbbd7bfad7279c26b57f10e8e2082de58f73d1b312b69f05c3e55846fad4f3f14ab589105189533871c327e298b
EBUILD jupyterlab-3.6.1-r1.ebuild 2747 BLAKE2B 813c9c866a457d54f51928b156f0cbb42b9529062683642af4005d7bb07909d163e3f7c9eb335a7e036fe2cd17218d73c68b93266545dfdc5f35d0cc0617fe8e SHA512 83a2a4912f292162e6cddbd6e095af0ddd88d91daf7f38cd669f197817d0972da469d7d3d27c89d64fae724c847b26b25c5b74e816e211ae261106a460a54ca2
+EBUILD jupyterlab-3.6.2.ebuild 2739 BLAKE2B 731fb108d8b61449b73300d8a7434c97b48ab32a87fe9998ac6286005f6ce2f3496df8e9df4c744a71811cbf294234d064665aa3da3e3c8336791eebff53fb73 SHA512 a24bcd5ea6e2286918f8e100bf12a9d12cf9ba1d659638fa111eef203d7964a5bf19a430f840861d18d2aabc2666429673e40bd07e0058ff4cf1b2c23da72c9d
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-3.6.2.ebuild b/dev-python/jupyterlab/jupyterlab-3.6.2.ebuild
new file mode 100644
index 000000000000..7f9e59dbde57
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-3.6.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=jupyter
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.19[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.16[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_ydoc-0.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-ydoc-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/nbclassic-0.2[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ test? (
+ dev-python/check-manifest[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/openapi-core[${PYTHON_USEDEP}]
+ dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}