summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-python/jupyterlab
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest3
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.1.10-r1.ebuild42
-rw-r--r--dev-python/jupyterlab/metadata.xml13
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
new file mode 100644
index 000000000000..3086e74e190d
--- /dev/null
+++ b/dev-python/jupyterlab/Manifest
@@ -0,0 +1,3 @@
+DIST jupyterlab-3.1.10.tar.gz 10997693 BLAKE2B 290276a24a92dce18ec97fca1bc20dfa79ffe9f905c49fe2e30606732fb892f15dfa9068ec53ed0ce7bfe274240f1857c381954b63c9ed1e6473715a57caa9b2 SHA512 c8e8dc850818fddee2354165bf49ca5c6c6d3daf9ed2f2c3d804c5e7f5f7c919ae613cceb686d7e4e60c6d1d5074223bee2c6ef6c6cf37346a280675a74e0e67
+EBUILD jupyterlab-3.1.10-r1.ebuild 1066 BLAKE2B f5b806db17417e9b9ab8ccbf027c48773de84f26c08946e329c460f0cba4a13da151d16f2172cc1b9cf7e696805146ecfe2a9d4fd82d461934158039a9e5438f SHA512 00db002f7e34af013e4822dfdd2853df7a2a29e5c77647e6349ef2edd0f314ed71d6ffea27f4f4e016ebba6a8ab30f0951c3c135b6924bb810a65337ca3f9bbb
+MISC metadata.xml 411 BLAKE2B 53e974d8fa346fed9b791132a5a9a751f082aa3c239d0aaccf7dc395327018ba406a9cf902a43bc7a4b3fe88940eb8261f9298b4e21e4db798051cef434997d6 SHA512 33b423696df18912c0dec1fd78408fed8939c15ca1d0ddbbb994d5869ca8ae2009dd3da311faf95fad57fb0fee19838bfb460ef8d14b2a7dd770823c55b8b6ff
diff --git a/dev-python/jupyterlab/jupyterlab-3.1.10-r1.ebuild b/dev-python/jupyterlab/jupyterlab-3.1.10-r1.ebuild
new file mode 100644
index 000000000000..3ee37f820bf8
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-3.1.10-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: package openapi et al
+RESTRICT="test"
+
+BDEPEND="dev-python/jupyter_packaging[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_server[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ dev-python/nbclassic[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-6.1[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+distutils_enable_tests pytest
+# TODO: package myst_parser
+#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
diff --git a/dev-python/jupyterlab/metadata.xml b/dev-python/jupyterlab/metadata.xml
new file mode 100644
index 000000000000..c701245a09da
--- /dev/null
+++ b/dev-python/jupyterlab/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyterlab</remote-id>
+ <remote-id type="github">jupyterlab/jupyterlab</remote-id>
+ </upstream>
+</pkgmetadata>